help -- data loss?

Hi. I’ve been working with Scrivener for a while now and have had zero problems, but have just encountered one that’s got me a little distressed. I’m in the process of drafting a book, and was working this morning in a document that’s one section of a chapter (each chapter is set up as a folder containing its sections). Something in my system began behaving wonkily – I think that’s the correct technical term – my external USB hard drive was clicking way more often than it ought to, Mail crashed, System Preferences became unresponsive, and a whole host of other weird behavior descended around the same time. I don’t know what the cause was, but it was clear I had to restart.

I’d been saving as I worked this morning, and so I quit Scrivener normally, shut down as many processes as could be normally shut down, attempted to force quit the ones that wouldn’t, and then tried to restart via the apple menu. When that failed (the Finder disappeared but the restart process stalled out there), I did a hard shutdown by holding down the power key, waited a minute or so, and rebooted.

After everything started back up, I reopened Scrivener, which reopened the file I’d been working in, but my window position, layout, and sizing had been reset, and my expanded Draft and Research folders were closed. No biggie, I thought, and moved everything back where it was.

EXCEPT: the document I’d been working in this morning – the section of that chapter – was completely empty. Nada. The document is there, where it ought to be, but with no words in it.

The good news is that between Time Machine and synchronizing to a thumb drive, I’ve got plenty of backups to the file as it existed before I started working this morning. But I’d really really rather have all of this morning’s work back.

I’m sure the origination of the error here lies elsewhere in my system – whether a malfunctioning external hard drive (incidentally, the .scriv file is NOT stored on that drive), a Mail failure, a Time Machine problem, or who knows what all else – but given that I’d been saving all morning, one would think that the Scrivener data ought to be retrievable somehow. Any help that you could provide in recovering this data would be HUGELY appreciated.

Seriously: I was brilliant this morning, and I’d like those words back. :slight_smile:

Okay, I’ll update myself. Here’s what I’ve figured out so far:

– The rtfd file that represents the missing document has gotten corrupted; it won’t open in TextEdit.

– When I open it in TextWrangler, it looks radically different from any of the working rtfd files in the .scriv package. Where the first few lines of a working file look like this:

{\fonttbl\f0\fswiss\fcharset0 Helvetica;\f1\fnil\fcharset0 GaramondPremrPro;}

\f0\b\fs24 \cf0 \expnd0\expndtw0\kerning0
profit, publishing, and the university mission

The first few lines of the corrupted file look like this:

[code]<?xml version="1.0" encoding="UTF-8"?>

.lockedInPlace binderSelection 10 binderSplitFrames {{0, 0}, {177, 692}} {{178, 0}, {914, 692}} [/code]

– Opening the BinderStrings.xml file in TextWrangler produced even more disheartening results: while the text of each of the other sections of the draft was present within the file, the missing section was, predictably, missing.

If this is the point at which I need to be told just to start reconstructing this morning’s work, that’s great. But if there’s any further hope for data recovery, that would be even better. And it would also be better to have a sense of what went wrong, and how it might be prevented from going wrong again.


What you say is the corrupted RTFD file seems to contain what should be the ui.xml data - which is very strange. It looks as though when everything started to crash, it may have stopped Scrivener saving properly somehow; if that’s vague it’s only because I’m a little lost as to what may have happened myself, as when things start playing up on a machine in this way it can have all sorts of strange effects on software. If you zip up the project and send it to support AT literatureandlatte DOT com, telling me which file is the one that you have lost, I can take a look at it and see if there is anything to retrieve. I might not be able to get back to you as quickly as normal as I’m in San Francisco for the Macworld Expo at the moment, but I’ll take a look as soon as I get chance.
All the best,

How bizarre! Thanks for the reply – I’ll zip up the file and send it your way. Enjoy Macworld, in the meantime… --K.