HELP! Did "save as" now ALL text in novel is gone!

I did a save as to back up the project going from July to August. But now all text in the old and new projects are gone. Completely missing. The structure is there. The chapter titles are there. I can’t find the text unless I pull an months old compiled version from a friend.

Manuscript is due in September and I’ve just lost tons of editing! What happened?

Whew, okay, I found the version from a couple of days back. But “save as” apparently didn’t actually do what it should have. I have an August version that is nothing but empty pages. The backup version I saved in another location, just in case, is also all blank files. That makes me feel queasy.

Scrivener creates a project backup every time you close, so I’m not sure if that’s what you found that has most of your work, but if not I’d give that a look. Open a different project in Scrivener and then go to Tools > Options… and select the “Backup” tab. These are all the options you can set for the automatic backups; by default Scrivener makes zipped backups and saves the five most recent into a backup folder it created in your user AppData folder. (You can change the location if you like to somewhere more convenient for you.) At the bottom you’ll see a button to open the backup folder in Windows Explorer, so click that and then sort the backups by modified date to find the most recent pertaining to this project. I’d go ahead and copy all of the relevant backups, since you may have opened and closed the project a few times in panic and the most recent may not have all the files.

Paste the copies on your desktop, then starting with the most recent, extract the backup by right-clicking the .zip and choosing “Extract All” or by double-clicking the .zip to open it and then dragging the contained .scriv folder to the desktop. I recommend renaming the .scriv folder to add the date of the backup to avoid confusion with multiple projects of the same name; it also prevents creating new backups of the backup that might overwrite your earlier ones. (You can also choose File > Back Up > Exclude from Automatic Backups once you open the project to avoid making a backup of it at all.)

After that, you can open the backup project in Scrivener. If the most recent is showing the same problem as the current working version, close it (after excluding it from backups, as above) and then try the next most recent backup. If you find a good copy newer than what you’ve already recovered, you can close it and move it to wherever you store your projects (e.g. your Documents folder). Be sure either it has a different name from the old version you’re placing, to prevent Windows trying to merge the folders.

Using the File > Back Up > Back Up To… command is the better way to create backups than using File > Save As, just for the sake of reducing confusion. I’m not clear what happened to your project causing the text to go missing, but one thing that does happen when using Save As repeatedly is that you are creating new working versions of your project, basically leaving a trail of partial version on your disk. (Each time you use Save As, you begin working in that new copy of the project.) This can end up getting messy if the wrong version of the project gets opened by mistake, since it will look like work is missing when in fact this is just a version saved prior to creating that work. Using the Back Up command creates a copy of your project without switching you to that new copy–so if you were working in Project A and create a backup, you’re still in Project A when you continue working, whereas if you are in Project A and do a “Save As” to “Project B”, you are now working in project B. It’s also handy to create the backups as zip files, as that makes it harder to accidentally open the wrong project, since you have to go through the extraction process first before you can open the project in Scrivener.

I’d try running a Windows search for some of the text you’re missing to see if it comes up anywhere–it might just not be saved in the correct location, but still be happily residing on your hard drive and easily salvageable. If you find any numbered .rtf files, right-click and check the file properties to see the file path for the documents–maybe they’re in a different copy of the project. You might also want to search for “.scriv” to pull up all the Scrivener projects on your computer to make sure you know which is which, in case there was just some Save As confusion at some point.

Thanks! I’m keeping this for future reference.

I have no idea what I did to mess it up, because I’ve saved different versions of projects before. But I found the “pre-moved” version. This was just weird. I can open the other versions. They exist on Dropbox. It’s just that none of the text files went with them. And of course I manage to do this to myself the same day I promise a delivery date for the project. Sorry for the panic, but this is one thing that really will give a writer a heart attack.

Hi, bumping this thread up because I’m having the same problem, and these tips did not help me.

Exactly what I did: Finished my writing for the night, hit save. Saved a new version on my desktop to be safe, closed the lid of my laptop to go home. Now keep in mind, I didn’t even close down the program or shut down my computer. I get home, open the laptop, and my project is still there with all my chapter folders and everything, but all the text within those folders: Gone.

Unless someone can give me some advice on what to do here I just lost like, 30,000 words of a novel. I’m about ready to cry trying to figure out what in the world happened. Someone please help!

Did you look for the project prior to the newly Saved As version, either just yourself navigating to the location in Windows Explorer, or trying the Windows search for the name of that copy of the project? Have you tried searching (in Windows) for some of the text? If the file path to the project had gotten changed while the project was open, you could end up with two partial copies of the project on your computer, with the new one mostly (or entirely) empty. If you’d been working in the same document in the editor for a while, this could’ve happened earlier without your noticing it until you tried to save a new copy of the project and things came up blank when the computer went to copy files that weren’t there. The missing files should still exist, though, at the changed file path, so they’d be recoverable into the project.

Did you also check backups? If you’re not closing the project regularly, you may not have many automatic ones, since they only run on project close by default, but still worth a shot, and of course if you do computer backups, check those.

I’m having a similar problem. I’m currently using a trial version of the Windows software just to get a feel for it. I imported a few files from my current manuscript as well as some into the Research section and then wanted to see how easily the program closed and opened. I made sure to back it up before closing the program, but when I opened it again, everything was blank. I still had all the titles for each chapter listed under the drafts section and beneath the research section, but all of the content was gone. I tried following your trouble shooting tips, but all of the backup copies the program saved are in the same state.

When I searched for some of the text, all that I managed to find was information saved in notebook format. I’ve considered copying and pasting from each one, but I’m worried the entire thing will just erase itself again.

I can confirm this one. :frowning: Using the beta version (, I did file-save as (after backing up the original), and the newly created project is blank. The original is fine, however.

As a work around, I’d suggest duplicating your scrivener project file in windows explorer or whichever file manager you use (entire thing) and renaming it, then opening that in Scrivener.

T|his doesn’t seem to to occur with beta but Scriv did have the need to want to save each Scrivening as I clicked on it. It kept coming up with the unsaved file asterisk near project name at top of screen. Also cannot recreate this using

I was getitng prompted for system encoding every time I compiled something, so I set the encoding to match my system (the recommended setting). When I do File > Save as for a project, it’ll save with text, but the next time I open the newly-created file, text will be gone. Also when I go into the project, the text files are blank. If I navigate around the new file, text will disappear.

I’ve attached the “good” one ( as a dropbox link (it’s my standard testing file). is the one created from File > Save As. … (40.9 KB)

Thank you all for the reports, although I’m sorry to hear of all the problems! We’re looking into this–as StaceyUK indicates, this isn’t a consistent problem, so it’s difficult to diagnose where the problem is and what’s triggering it. I appreciate all the information you guys can give, and any more details are welcome. Could everyone having a problem let me know what version of Windows you’re using, including whether it’s 32- or 64-bit, and verify your version of Scrivener by checking Help > About Scrivener? (There are currently four versions floating around, due to the NaNoWriMo trial, so if you didn’t already indicate this, please check so we can keep track.)

What do you mean by “notebook” format? Are these copies of your files from before importing into Scrivener? Scrivener saves your text as rich text files (.rtf) and synopses as plain-text (.txt), so if you found these via a Windows search, they’d be typed according to what your default program is for opening those files, e.g. WordPad for .rtf files and Notepad for .txt files. Text files created in or imported into Scrivener will have just a number as the filename, which is its internal ID Scrivener uses, so if you found files like “5” and “32”, these are most likely files in a project folder, or files that belong there but have somehow gotten moved.

This should only occur when compiling to plain-text, if you had the preferences set to prompt you for import/export on plain-text files. Is that what you mean? Have you been importing plain-text files as well, also using the system-recommended setting? It shouldn’t otherwise affect Save As or backups, since these are just copies of the internal files, rather than conversions.

I’ll take a look at the linked projects; thanks.

To clarify, does this mean that a document’s binder icon appears to have text, but when loading that document the text is missing in the editor and the icon reverts to blank? Or do you actually initially see the document text in the editor and see it disappear?

My OS: Windows Vista Home Premium SP2 32bit. Other specs are in my sig.

I’m using, 32 bit, since it’s 32 bit WINE. (My OS is 64 bit, though.)

Yes to both. It’ll look like there’s text when you open it (icons will have squigly lines) but then go blank as the text goes blank. When you first navigate around the project (immediately after doing File > Save As), text will appear, then rapidly disappear. (And will stay gone.)

This just happened to me! I was backing up to drop box, some of the text files have gone missing. I managed to find them and am reconstructing the file.

This is a very serious bug-- people are losing work, misplacing it, and having panic attacks …

The fact that standard operating procedures for saving or backing up work can cause you to misplace data is very concerning. At the very least the possibility of this occuring needs to be stressed to users so people can know of workarounds before they lose data.

Then post details that MM mentioned. They can’t fix it, if they don’t know specifics.

Additionally, text going missing when saving to Dropbox can easily happen if one doesn’t follow the best practices outlined for working with file synching programs outlined here. It may not be the same bug at all - it may in fact just be that, for example, you shut down or interrupted Dropbox’s sync before it had finished, which would result in the missing files.

Question to the Scrivener folks: is there a way for us to do regression testing? It used to work, but I forgot the last version it worked in

bluehour - I’m very sorry you had a problem with your backups and went through a panic, though I’m relieved to hear you were able to find and restore them. We are certainly aware this is a serious issue and are doing all we can to track down the cause and rectify it, so all the details you can provide your system configuration (what version and architecture of Windows, whether you’re running on any sort of virtual machine, what version of Scrivener you are using, whether your active and backup project copies are on a local or external drive) and the steps leading up to the problem and the discovery of it would help us greatly. As temporalranger mentioned, Dropbox adds another level of complication to the matter, as it introduces the possibility of sync errors. Since you were able to find copies of the files, it would also help us to know where and how you found those (and may help other users experiencing this issue as well).

garpu - I’ll check with Lee on this, as currently we don’t have any versions available for download but the official 1.2.5 release and the beta, but he may be able to provide an older build if he thinks the testing would help.

OK, I apologise up front because I know I’m being dense, but I just want to be dead clear on this: You se the document’s text in the editor and then as you are watching it suddenly disappears from the editor? This is a hugely different issue from the binder icons having lines and then switching to blank when you click around, as that’s just the search and .xml file playing catch up.

No…if you have one text selected right after doing “save as,” the text will be there, and the icons will indicate that there’s text. But then when you switch to another document in the binder, the text will disappear, and the document you jumped to will be blank. If you go back to the first document, that text will then be blank. It’s as if it’s grabbing what was stored in memory, but not actually copying? That’s my wild-ass guess.

Would it help if I tried to get a screencast of it? (I can work on it tomorrow. 'Tis late here.)

Following up with this, Lee’s released a new beta,, which can be downloaded from here. We would appreciate it if those regularly seeing this blank document bug could test the new version and let us know if it changes anything!

Additionally, a new question: Are any of you running Scrivener in any sort of compatibility mode? (e.g. in Windows 7 if you right-click the Scrivener program .exe and choose Properties, then switch to the Compatibility tab, are you running Scrivener in compatibility mode for Win XP SP3?)