Help me properly set up my novel's styles/formatting

Hi. I’ve been using Scrivener 3 for a year or two now and it’s clear I’m doing something deeply wrong as I’m having endless trouble with styles being lost during Compiles, weird indents, spaces disappearing (when a style changes), etc.

Can you help me set up my document in a best practices kind of way?

It’s a novel. I’m using Folders to separate each chapter, with scenes as new Text pages within each folder.

The main issue is this: I need a way to format certain dialogue using a different style. (I know this is tacky; the reason for it is complicated but justified, I swear!)

Essentially I have

(1) the manuscript’s main text, including most dialogue—which should just use a default Times/Courier formatting, with occasional italics etc which I would preferably apply just by using CMD-i;

(2) dialogue by character X, which needs to be in a second, different font;

(3) dialogue by character Y, which uses the same font as (2) but should appear highlighted (ie, with a background colour);

(4) text that appears in-line as part of (1), but which should also take a highlight (background) colour.

Right now, each of my scenes is formatted as Body text, and I have created (1), (2), (3) and (4) as Character Styles. However when I compile the manuscript (as a docx at least) I lose the highlighting in (3) and (4), and I’ve also had problems with disappearing italics in (1). (In the end I had to create an “(1) with italics” style. Indents also seem inconsistent across the document.

Clearly I’m doing something, or several things, wrong. I think there’s some kind of clash happening between Body text and Character Style (1), but I also don’t know how to fix or deal with the highlighting issue. What’s the best practice for setting up a manuscript like this?

I’m a professional working novelist so the stakes on this do feel high; I appreciate your help!

Define (1) as your default No Style formatting. Don’t use Body Text.

Are the dialogue tags for (2) and (3) also in their special formatting? If so, use a paragraph style. If not, define (2) and (3) as character styles.

You can use a style for (4) if you want, but I wouldn’t. Just use the highlight command.

It sounds like you want to use the same formatting in the Editor that you’ll see in the finished manuscript? If that’s the case, then start with the Default Compile format. Use Section Layouts to control which headings appear, but don’t change any of the formatting options. Section 24.2 in the Scrivener manual discusses the Section Layout options in detail.

Are the inconsistent indents random, or at the beginnings of scenes or other sections? If they’re random, turn on View -> Text Editing -> Show Invisibles, and look for stray tab commands. If they’re at the beginnings of scenes, check the Settings options for the relevant Section Layouts.

For the disappearing highlight issue, check the “gear” icon in the righthand pane of the main Compile screen. There’s an option to strip highlighting there.

Katherine

Thanks for all this help!

I’ve begun to apply these changes and what I’ve found is that the highlighting defined in my character style (3) DOES appear when I compile to PDF, but not when I compile to DOCX…

Which probably means that different compile options are set for the two formats.

However, what are you using to inspect the DOCX file? Word’s autoformatting options can sometimes intervene in unhelpful ways. One check would be to compile to RTF and open the file in TextEdit.

Katherine

Thank you again for your help, I really appreciate it.

Compiling a new draft with the latest version of Scrivener and disappointed to find this bug has still not gone away:

Highlighted text (the highlight is defined as part of a character style) is not retained when I compile to RTF, DOC or DOCX.

It is retained when I export to PDF or ODT, however it does not transfer when I copy/paste this formatted text into Word.

I imagine this must be an error in the way Scrivener interprets highlighting vis-à-vis RTF or DOCX.

It’s extremely problematic for me because my document makes extensive use of highlighting for identifying which character is speaking. (Don’t ask - i know this is dumb and unconventional.) And I really need to be able to use a powerful program like Word to manage the compiled manuscript. Can anyone help? Thank you.

Can I ask what appears to be a couple of dumb questions? :slight_smile:

  1. Do you have “Preferences > Sharing > Conversion > Use Enhanced converters …” turned on?
  2. If so, have you tried turning them off to use the export format Keith has developed (just ignore the warning panel that comes up if you do that)?
  3. Does that make any difference?

Mark

Hi Xiamenese,

Thank you so much for this suggestion.

Yes, Enhanced Converters was turned on.

I tried turning it off and exporting a test in DOCX. Unfortunately, no change - the style’s highlighting is still not preserved.

But to my astonishment and pleasure, it WAS preserved when I turned the enhanced converters OFF. So I think it was that new innovation scrambling the code.