Help please turning off red under a valid word

I am using the word “waterbath” which is found in the dictionary. It is flagged as incorrect with a redline under it. The options to correct this do not include “ignore” like I am used to seeing in WORD. I need the redline to go away. This is my first week using Scrivener so type slowly when you reply thx : )

Do you not have “Learn spelling” as an option when you right-click on the word?

FWIW I just tried this on my US English Mac mini running High Sierra and it works fine:

ScrivenerLearnSpelling.png

If you are on a newer version of Mac OS like Catalina, make sure that you have the latest version of Scrivener installed to fix all of the OS-specific glitches that can arise.