Help! re: Scrivener Comments


When I make a comment it places a default name/date in the comment field. How can I change what the default is? Also as the name is completely wrong, somehow that of a coworker. I am stumped as to how that occurred. He is the IT guy at my work and set up my original iPad. Somehow that is connected but I don’t know how.

I purchased scrivener through the app store via my iTunes account so it is certainly strange.

  • William Stanley

Every Mac computer contains a “primary” address card in the Address Book software which identifies the owner of the computer. If you are in an office, it’s likely got the information of whoever set up that computer initially or used it before you did. To change your Mac’s owner details, use Address Book, and the Card/Go to My Card menu command.

If he set up your iPad, potentially Apple’s “It just works” iCloud system overwrote your computer’s card with the iPad card. :slight_smile:

many thanks!

That was the issue. setting up iCloud took the iPad info.

A quick update for those who are experiencing this problem again…

I guess things have changed since this post and this solution no longer works for me under OS X Mojave (10.14). Instead i had to go to System Preferences > Users & Groups, unlock [“click the lock to make changes”], then right-click on the Current User, select Advanced Settings, and finally change the ‘Full Name’ field to the name you want.

This thread is nine years old, and only relevant if you still use v2. The “Full Name” field is what Scrivener will use if it cannot access the Contacts (used to be Addresses) database, or if you do not have a personal card filled out.

Furthermore, version 3 also has its own author information preference pane (in the General tab), which can override either the system or the contacts info.