HELP! Recovering Footnotes and Comments after updating!

Hello fellow Scrivener users,

I recently posted the question/problem written below, but now I have come across a more sever issue. I have since updated my Scrivener from 2.8 to 2.9, but now, many of my footnotes and comments are missing.
I will leave the text from the original post below for some background. I will begin and end it with asterix. The new problem follows the original post.

*I would like to ask your advice on an issue which is severely cutting into my productivity time.
I have recently installed Scrivener 2.9 on a computer at home, opened a file with it, and now I cannot open this file on an older version on my laptop using Scrivener 2.8.

I use Scrivener on a MacBook High Sierra 10.13.6. I was at home yesterday without my Macbook, so I decided to install Scriv on the MacMini (also using High Sierra). I downloaded 2.9. I opened a file, which had to “update” to be compatible with a new version.
Now, I am back in the office with my Macbook’s 2.8, and I cant open the file. I have tried to update Scrivener 2.8 to 2.9, but there is an error message saying that my Mac is not optimised to handle this version.

So, now I can’t open my file, or even update to a newer version of Scrivener.

Should I uninstall Scriv 2.8 and then try to reinstall Scriv. 2.9? Or should I try something else? I save my writing/research file in a dropbox folder, so I am assuming that even if I uninstall Scriv. completely I’ll still be able to reload a file once I reinstall it?*


I have since been able to open scrivener 2.9 on my Macbook. However, in many o f the writing files, there are no footnotes or comments!!!
I can see where the footnotes are supposed to be in the editor - but instead of a grey box surrounding the text, it is just a blue highlighting and underline, kind of like a hyperlink on a webpage. Also, there is nothing in the inspector panel under footnotes.
However, when I click on the “link”, an error message comes up saying “There is no application to open this”.
I even tried exporting a file as a Word Doc to see if they were there, but even in the word document there is nothing.

Can somebody please help me sort this out?

Thanking you in advance.

Hmm, well one thing worth mentioning is that there is very little difference between 2.9 and The only thing that was changed is that 2.9 now accepts serial numbers for both 2.x and 3.x, for those that have bought or upgraded to version 3 that still need to use 2.x for some reason (Windows or older Mac compatibility). There is no project update necessary—likely you’re loading an older project (perhaps it hasn’t been opened since 2.7 at least), if you got a message about updating it.

The “optimisation” error you refer to is merely macOS informing you that the program you are trying to run is 32-bit, and support for it will be dropped in the future (probably 10.15, next year). This is not a serious error and it can be ignored.

Now regarding footnotes and comments, it sounds like the files that hold that information are either missing from the project or incorrectly named. The most common culprit for a result like that would be some sort of external mechanism that is messing with Scrivener’s files. Dropbox, iCloud, Google Drive and such things are the most common systems that fit that description. For example iCloud has a questionable feature that is on by default, whereby it will delete files from your disk if it deems them as “old”, leaving the only extant copy on their server. What will ordinarily happen is if you try load the file it will download it automatically—but we do not yet know the full impact of that on formats like Scrivener’s, that depend on many small files to store your data. If iCloud deletes the comment files, will it download them if the software looks for them? And surely even if it does that, in the time it takes for Scrivener to load the project it is nearly certain that there will not be enough time for these files to download, meaning that the state of the project when loaded was incomplete.

If you use iCloud to sync “everything”, I would strongly recommend going into your iCloud Desktop & Document settings and disabling that feature. I’m not sure how to get it to download a complete copy of the project, if that is the problem. I don’t use it myself and only know a bit about it.

Also if this only happened recently, go to your backup folder and look for copies of the project that are not missing comments and footnotes. With luck the project will be recent enough that you can simply replace the current working copy with it.

Amber V,

Thank you for the reply. I actually use Dropbox as a place to keep my working and back up files. Perhaps your suggestion of synching issues may have something to do with it. But it is something I will be able to keep in mind in future, or look into.

As for the backups - well, I completely forgot about those! They are also kept in Dropbox, but as they are zipped, they werent muddled up like the working file. I was able to unzip a backup and use it with Scrivener 2.9.

Thank you for the advice and help!

Just jumping on to say thank you for saving me from my moment of panic. My footnotes on an essay disappeared after moving from my desktop to my laptop and the reminder that Scrivener saves a separate backup meant nothing was lost and my moment of panic was swiftly ended. So thank you!