HELP!!! Scrivener ate my novel!!!

Hi, I’m participating in Nano and I downloaded the free trial two days ago. I wrote 2k+ words of my novel over the course of last night and today. An hour or so ago, I had to shut down my computer to complete some updates, and when my computer started back up, I opened scrivener to continue working on my novel. Scrivener itself opens, but it will not let me open my documents on the program. I have even bypassed Scrivener and tried opening my novel from the “My Documents” folder on my computer. Still no luck. I tried shutting down Scrivener so I could re-open it and try again, but it won’t even shut down.

The program won’t run period on my computer. I open it up and it says it’s open, but no windows pop up. It won’t let me open old documents and it won’t let me start a new document. No function of the program works, period. I can’t even “quit” (shut down) the program without completely shutting down my computer, and that’s only if I manually hold down the power button on my computer. I have shut down and restarted my computer like this twice, and it has made no difference. I am afraid to uninstall and reinstall Scrivener for fear of losing what I have written so far of my novel.

This is absolutely insane. All I want is my hard work back. I have no idea how to get to my novel and I am FREAKING OUT.

Has anyone had this problem? How can I get my document back? I really hope it’s not gone forever. Please help!!!

Can you break down how you’ve attempted to open your project in Scrivener, step by step? For instance:

  1. Double-clicked Scrivener icon on desktop
  2. Clicked on the “recent projects” button in the Template Chooser window
  3. … but no projects were listed?

Is it possible that the window is opening somewhere off of the screen? I’ve seen this happen on the Mac when I disconnected my laptop from an external monitor. Try using “Mission Control” (4 fingers swiped up, if you have that set in System Preferences->Trackpad->More Gestures.

Hi, Marieee,

Don’t panic. The good people of Scrivener will help you figure it out. Scrivener is an amazingly stable app, so it is going to be okay.

And of course, you need to stay calm because your Nano word count clock is ticking, so stay cool and keep up with your writing in another app just until this gets worked out.

Okay, now:

  1. It would help if you can tell us what version of OS X is on the Mac you are using.

  2. One thing you can try is rebooting in Safe Mode and seeing if you can launch Scriv without the same problem occurring. That will tell us something about where the hitch is.

For instructions on booting in Safe Mode:
http://support.apple.com/kb/HT1455?viewlocale=en_US&locale=en_US

–gr

Trashing the Scrivener application and reinstalling won’t affect your projects; they’re separate files on your drive (actually bundled folders of files) and will stay there until you specifically delete them, just as a .doc or .mp3 file isn’t deleted just because you uninstalled Pages or iTunes. So if the other suggestions don’t resolve the problem, doing the reinstall is probably worth trying.

Before that, you can try launching Scrivener and checking for any activity in the Console (in the Utilities folder within Applications); filter by “Scrivener” to only see messages that may be relevant, and then copy and paste that here. You can also open Activity Monitor (likewise in Utilities) to check on Scrivener–does it give a “Not Responding” message beside Scrivener’s name? From here you should also be able to force quit Scrivener if necessary without having to restart the computer.

I saw something weird once running on OS X Lion where Scrivener appeared to be running and I could open projects from the menu but they wouldn’t be visible on the desktop. According to Scrivener’s dock menu the projects were open and not minimised; they just weren’t visible, and selecting them from the menu didn’t change that. I think it was a Lion issue with having automatically restarted all open programs from when I last shut down, though I can’t swear I hadn’t just launched Scrivener manually after the restart. I was also hopping around through different desktops, which may have affected it. In any case, you might be seeing something similar, and quitting Scrivener on its own (rather than as part of shutting down the computer) may clear it up. I do think I was able to quit just via the application menu–no freeze like you’re describing–but you could try using the Activity Monitor to quit Scrivener, and then rebooting and launching Scrivener while holding Opt-Shift to prevent Scrivener automatically loading any projects that were open when it quit. That should bring up the Project Templates window in the middle of the screen, and you can then try opening your project from there. Even if that works but the project itself won’t load, we’ll be a step closer to discovering and fixing the problem.

Also, something that should make you feel better: locate the .scriv project in the Finder, Ctrl-click on it and select “Show Package Contents”. In the window that appears, drill down into Files > Docs. You will see numbered RTF files in there. Try double-clicking on them to open them in TextEdit. You should see the words you wrote in one of them. This should at least make you feel better, knowing that you’ve lost nothing, while we work out what is going on.

Thanks, everyone, for your help and support! I was able to get my text back at least, thanks to your suggestions of “Show Package Contents” so I am very grateful for that advice! Right now, Jeff from tech support is walking me through the process of un-installing and re-installing Scrivener in a way that will work better for my computer. So a big thanks to Jeff!

Thanks again for all the help!!! You guys are great! :slight_smile: