Help! Scrivener has become very sloooow..

I use Scrivener every day for many hours. I never had a problem with the program. But ever since I have switched to Leopard large projects in Scrivener have become very slow. I type a sentence like this one, and I am at the end of the sentence when the first word of the sentence finally shows up on the screen.

Now, I am sure this has to do with my change to Leopard. I have an iBook 1,2 Ghz, 512 MB RAM. No enough RAM, right? But after searching some help forums on this subject it seems that the amount of RAM isn’t the problem in this case but the speed of the CPU.

I installed a program called MenuMeters which monitors the performance of my system and it clearly shows: there is still ample space on my RAM when I am in Scrivener, but the CPU is running at 100% most of the time.

I know practically nothing about computers. And I certainly don’t know how to fix this problem.
Do I have to go back to Tiger?
Is there something I can do in the System Preferences to make my computer run faster?

So I cry out to all the technological specialists on this forum: Please help!
Bild 3.jpg

Have you tried setting your auto-save period to something longer in the General Preferences? Try changing it from 2 seconds to 120 seconds or some such, and use manual save when you want to be confident of saving your work. It may just be that the auto-save is kicking in, especially if you pause for a couple of seconds whilst typing.
Best,
Keith

Thanks for the answer, Keith.
I just set, as you recommended, the autosave to 120 seconds, but there is no difference. Still very, very slow.
There is no problem when I am writing at the end of given document; but when I am writing or correcting somewhere within it, this is when the slowdown occurs.
I guess I could work around my problem by breaking my documents up into small portions, but I would prefer not having to do this.

How long are your documents? How big is your project? Is this in full screen mode or normal mode or both?
Thanks,
Keith

The project that I am working on contains ca. 14,000 words (i.e. 86,000 characters). It has no images, just letters. The slowdown happens in full screen as well as in normal mode.

I have been experiencing this as well with all my Scrivener projects, including one I just started. I haven’t had time to really pin anything down in terms of why it has suddenly started to happen, but I have also recently upgraded to Leopard. Not sure how to go about finding out what the problem is, so any suggestions would be great. I haven’t been using Scr. because of it and because of my lack of time to devote to the issue. I also haven’t really needed to use Scr. in the past few weeks but will soon.

Let me know what to do to try to isolate the problem. It’s happening a project that is huge and in one that has nothing in it save one file. I’m using an iBook G4 running 10.5.1. I’ve been using Scr. all along on the same computer with no problems.

Thanks,

Alexandria

Rochefore:

Not a specific answer, but you really should up the RAM in your iBook. I’m writing on an iBook G4 which, at 768 MB of RAM (or whatever that number is) was quite lagg-y with Leopard, but after an upgrade to 1.2 MB is much more responsive.

S

Yes, I was planning on doing this anyways.

But still – isn’t what “MenuMeters” tells me that adding RAM will not help me in my case?

Or do I misinterpret this?

I really don’t know. I wish I knew more about computers.

But thanks anyways for your comment.

If someone could send me a project with this problem (zip it up and send it to support AT literatuereandlatte DOT come) then I can investigate the issue (I’ll try it out on my old iBook 1 GhZ, which I’ve just updated to Leopard - but I really need a project that is known to exhibit the issue).

You can scramble an existing project for these purposes like so:

  1. Make a copy of the project in the Finder.
  2. Open the copy in Scrivener.
  3. Use Edit > Find > Project Replace to replace random letters, e.g. “a” for “q”, “t” for “b” etc, until the text is unreadable.

Then check the problem still exists, zip up the project (either via Backup To or by ctrl-clicking on the project in the Finder and archiving/compressing it that way), send it to me and explain EXACTLY what to do to see the problem.

Thanks,
Keith

One extra thought… Check your paragraph formatting. I do remember that the text system sometimes got slow when there was a right indent on long documents (which usually affected certain documents I imported from Word).
Best,
Keith

Okay, I have some VERY bad news.

I just tried the project rochefore sent me on my iBook 1GhZ, 768MB RAM. I saw the problem immediately - typing in the middle of some Edit Scrivenings text with around 14,000 words was slow as hell. It was awful, pretty much unusable. This was alarming enough, but I figured at least I could look for what the problem might be.

But then I copied and pasted the text into TextEdit - and experienced EXACTLY the same slowdown.

Then I copied it into WriteRoom - again, the same thing.

In other words, it looks as though the Apple text system has suddenly become glacially slow on old machines running Leopard. This is a bit of a bombshell. I’m hoping to submit a report to Apple about this, but this is not good. It basically means that you are going to have the same problem with any program that uses the Apple text system.

I urge you to copy and paste offending text into TextEdit and see if you see the same thing there as I did.

Best,
Keith

I can confirm what you say. On Pages it is the very same problem. Word (2004) though is ok.

But, I discovered, that when in Scrivener I align the text on the left rather than have it justified the problem disappears!

I guess I can get used to having it aligned on the left. Still – if there were a solution I would prefer that.

There will certainly be updates of Leopard. Maybe Apple will take care of this problem. It is a bit embarassing that MS Word doesn’t slow down.

The fact that the same problem occurs in Pages is a good sign. I believe Pages uses the same basic underlying text system (though I could be wrong), just enhanced and modified by the coders who know it best. Hopefully a fix to Pages will entail a fix to the text system in at least this one regard…
Best,
Keith

Time to use all your sway with the Apple folks, Keith. Call in those chits.

That’s interesting, because when it was happening I did NOT find this problem repeated in TextEdit. And my file did not have more than a few words. In fact, I transfered what I was writing to TextEdit to complete it, where it worked just fine. I’ll have to check into this more when I have the time. Sounds like others have confirmed what Keith has found or have found other solutions. I’ll check back if I don’t get it resolved.

Alexandria

After Alexandria’s post I checked and double checked and triple checked my writing programs again.

Word (2004): minimal slowdown, hardly noticable

Scrivener: as described above in my first post

Pages 08: Worst Slow Down of all

TextEdit: No Slow Down at all

All the best to you,

r.

Have you checked out what’s running in the background of the applications that run slow – and of the ones that don’t, for comparison?

Like, the substitutions are new in Leopard, and maybe grammar and spell checking have changed. Stuff like this has always been good for causing slowdowns.

Well, if typing works as expected in TextEdit, how does that fit with the theory that it is the Apple text system? I haven’t checked out what’s running in the background of programs. I did try rebooting the iBook and had only myNotes and Scrivener running and had this problem. Also tried creating a brand new Scrivener project and it started happening after a short time. I haven’t tried it since. I did have Scr. open yesterday and tried typing in a project file about 22 MBs large and started a new file. The lag was very, very slight. But when I tried adding onto a file that had 2500 words, the lag was much more noticeable. Not sure what to do about all this. I haven’t needed to use Scr. much since upgrading to Leopard, but I’ll be starting my book project in earnest (been doing fundraising up to now) quite soon and then I’ll most definitely need it. I surely can’t afford a new computer right now! Also, my iBook still does everything else I need it to extremely well and I love it. Any thoughts on what to do? I’m willing to do some troubleshooting if need be–just need to know what that would look like!

Thanks,

Alexandria

I just noticed that I had typing set to justify in Scr. I removed this default option and I do believe the lag improved. I’ll have to do more testing. If this simple solutions works, then my problem is solved, since having it justified is more an aesthetic issue. I just like the way it looks when I’m working. But I will do my formal work (i.e., getting the thing ready for sending out) in another program, so I can justify all I want when doing that! I’ll get back and let you know later if this is a genuine solution when I have time to really try it out with more files and projects.

Alexandria

Hmm, I never use spell check or grammar check. They are both turned off.

Alexandria, I noticed the same thing (see my post further up). If the text is aligned to the left rather than justified the problem disappears.

Still, I would love to know the cause so I can take care of it.

Thanks,

r.