Help - Speech disappearing in Scriptwriting Mode

I am currently writing a full length play and have nearly finished the first draft. I am at the stage where I am using Edit Scrivernings a lot in order to read the whole play through to see what scenes need finishing etc.

Unfortunately I am noticing some scenes have speeches missing. The character name is there, but what they say has disapeared.

In a couple of scenes this is just the odd one or two lines, which up until now I have assumed was my mistake and have rewritten the line. However, having just opened the document to work on it more, I now have one scene where half of it has no speech, just character names. In this section there are the odd one or two lines where there is speech, but the majority has dissappeared, to the extent that I can’t work out what the characters have said.

I’ve just restored an earlier back up, but found it was backed up before I had added to the scene. Mysteriously though, there are odd lines of speech missing in that back up, that have reappeared in the current version.

What I thought was a minor issue of my own doing is now a major issue in that I have lost confidence and am frightened to continue writing since I have no idea which line of speech might mysteriously disappear from an already written scene.

A few lines here and there I can cope with; 50% of a scene, I can’t.

Any ideas, please?


This sounds very odd - I can’t see how random speeches could disappear (it would be very specific, too, as dialogue isn’t any different from other text as far as Scrivener is concerned). You say that some of it has somehow reappeared - but that would be odd too. All of which is just to say that I think something else must be going on here. If you go through the documents one by one, do they look okay or is text still missing? If you go through every text in the project, including anything in the Trash folder, is anything in there? If you open up the Console (~/Applications/, have any errors been reported there?

How are the documents split up in the binder? Can you give any more details about what you were doing at the time you noticed this?

Scrivener certainly can’t just eat random parts of text on its own, unless there is a serious bug in Edit Scrivenings that no one else has noticed, so I’d really appreciate more details. I am of course happy to look at the project too.

Thanks and all the best,


I am sure I have discovered what is going on. I opened up another project which I worked on for a few days a couple of weeks ago. This was a stage adaptation of a novel. I had the novel in one long text file and then worked on it by adding character names to the speeches etc. I did a lot of work in three days and worked my way through the whole novel.

I found a piece of software to help. It had come up in my RSS feed re new software from the Apple site just at the right time. It is ‘Presto’. ( … resto.html ). I have the demo version. It’s a simple auto-complete utility that works system-wide in any text application you set it for. You set what you want to auto-complete, in my case character names, and then the short cut, ie aa for AARON and jj for JAMES. When I was doing the novel adaption this saved a lot of typing.

Having found it useful for the other project, I started using it for the current one, and it has worked well. Thankfully most of the play had been written beforehand so only three scenes are affected. Not all the speeches disappear, but in the previous project, where I used it all the time, as a rough estimate about 50% is now missing.

Needless to say I will now NOT be using ‘Presto’.

When you mentioned the trash, I found a scene from the other project where I had copied it to the current project by accident; so thanks, as I would never have worked this out otherwise!

So there you go! You can rest easy Keith. It’s ‘Presto’ causing the problem. Not sure what you’ll do with that information, but at least you now know. Certainly put my mind at rest!

Thank you so much for your very swift reply and help with this.

Thanks for the update - and that’s a great relief to me that it’s Presto and not Scrivener! I thought it would be very strange behaviour, but if another app is intercepting typing then I suppose it makes sense.

Scrivener 2.0 will hook into Snow Leopard’s auto-correction features (and provide its own for pre-Snow Leopard users), so you will be able to do this directly in Scrivener then rather than needing a third party app. In the meantime you can always add character names to the auto-complete list via Edit > Edit Autocomplete List and then hit opt-Esc or cmd-period after typing the first couple of letters of the name to bring up the auto-complete list.

Anyway, glad it wasn’t Scrivener causing the problems!

All the best,

P.S. Thanks for the kind tweet!