Help! Still can't get Scrivener to install on Linux Mint 13

I’ve been using Scrivener on Linux Mint 13 and it’s been working great. I only wish it hadn’t “expired” (on December 1), because I can’t get 1.7.2.3 to install for anything. I’ve never had any problem installing new versions when previous versions expired, but I’ve tried both the deb and the tar downloads, and four lost writing days later, still can’t get Scrivener to open. When I install, Scrivener shows up in the usual place, under Office, but when I select it, nothing happens.

(I mentioned in another post that I have a Windows license for Scrivener, but that’s installed on my tablet, which is not going to work for me right now.)

Is anyone else having trouble getting Scrivener 1.7.2.3 to install?

Is there some dependency I’m missing that I could install?

On thing that you might want to ensure is that you have the correct version installed, as in 64 or 32 bit. I had this problem when I switched my desktop over to scrivener.