Help: "This application has requested the Runtime..."

All of a sudden, Scrivener won’t start up. I get an error message labeled “Microsoft Visual C++ Runtime Library”:

This application has requested the Runtime to terminate it in an unusual way,
Please contact the application’s support team for more information.

Can anyone help?

PS: I use Scrivener on Windows 7 and have not had any problems with it before.

Yep. reinstall the 2008 C++ redistributable. There are a zillion threads here pointing to it, or you can download it straight from MS.

I have tried EVERYTHING listed here:

  • installed previous version of Scrivener
  • installed c+++ 2008. AND 2010.
  • removed files from Scrivener-directory
  • put the files back again.
  • updated c+++ using windows update
  • reinstalled NEW version of scrivener
  • uninstalled Scrivener, and installed the old version “fresh”
  • uninstalled Scrivener, and installed the NEW version “fresh”

And still no luck, if you can call it that. Scrivener (any version) will not start.

I get the “runtime error” every time


I had the same issue. The only solution was to delete the scrivener entry from the registry: HKEY_USERS\S-1-5-21-2334668373-3301494527-1037224956-1001\Software\Scrivener mine was here. I have deleted this and the old version worked.

It is shame that I have spent countless hours solving the issue and still cannot use the new version.