Help with formatting

Hi All. I am using the academic template, but I want to change a few things. First, I don’t want the first line of a new paragraph to be indented. How do I change this setting. Second, I can’t seem to get the block quote style to be as I want it. For some reason, even if I add a new format option, when I apply it to the text it is not appearing as the format I copy it from. What am I missing here? It all looks like it should be so simple, but changing these style feature does not seem intuitive or easy to me.

Firstly, the things you are referring to here are not template features, just in case you were unaware. Project templates are a way of setting up a project’s initial state, but after that point it’s just an ordinary project like all others. Meanwhile things such as the default text formatting in the editor are set at the application level in the Formatting preferences pane. If you don’t want indents while you write, then that is where you would set that up. This article in the knowledge base has a little more info on the topic. Formatting Presets are also global; every project uses the same set.

It’s hard to say without knowing what procedure you used. I don’t have any problems with the following:

  1. Click into the example paragraph that I designed.
  2. Use Format/Formatting/New Preset from Selection.
  3. Give it a name, and make sure “Save all formatting” is set (if I want such things as italics or bold to be saved, otherwise “Save paragraph style” should suffice for a block quote).
  4. Click OK.
  5. Click in another paragraph and use the style menu in the Format Bar to apply it.

Hi Amber many thanks for your help.

The procedure you describe is exactly what I am doing and the new paragraph is not formatted as the one I have copied. The one I copy is indented and justified with X font size and Y line space, but then why I apply it to the new paragraph none of those features appear. I’ve tried deleting old formatting presets, doing new ones, but nothing seems to work. It doesn’t happen when I use a blank template and that seems to work fine, which is why I thought it might be something to do with the template. I’m at a loss.

Also, how do I remove the first paragraph indent? Sorry, but that link you sent me does not seem to address this very basic feature.

Sorry to bombard everyone with questions, but when I open up the Preferences > Formatting, it says Main Text Style, how do I get it to alter the block quote for example?

dropbox.com/s/usx64fegezeiz … 4.png?dl=0

That’s a new one to me, I am not sure what is going on there. So to make sure we are on the same page, you mention that it works when using a project created from “Blank” but not one of the non-fiction templates—so does that mean you create a preset in the blank project, then switch windows to the non-fiction project and apply but nothing happens?

Maybe it’s something with the source text itself, did you import or copy and paste the text from Word or something? You could probably check for that by dragging a document from your non-fiction binder into the binder of the blank test project you made—that will copy over nearly everything about the item. Now can you apply the formatting there?

Just use the formatting tools and menus in the mock editor to set the look of default text. If you’re asking about how to use the ruler in general to alter the position of the first-line indent handle, there is some help in the user manual, under §15.4.1, starting on page 207. In fact that whole section of the manual might be useful reading.

It does just what it says, main text style and nothing else. You wouldn’t create or modifiy formatting presets here, the only thing that setting does is set up how text in new documents appears. Use the main editor to create and modify presets as you write.

Thanks again Amber, to be honest it’s not my problem but a colleague. I persuaded them that scrivener was great and now they are having problems, so a bit embrassing. From what i understand it’s all been written in Scrivener, not imported or pasted. They started writing a new document with the Academic template, but the formatting presets don’t seem to be operating as they should.

So, for example, they can get a piece of text, format it exactly as they want, for block quotes, select that text, and then try and redefine the block quote preset with the formatting of the selected text. So far, so good. But when they try and apply that preset to another piece of text the formatting is all over the place; the margins and indents aren’t they should be, and spaces appear in the sentences and even the font size changes. I’m suspecting that there is already some formatting applied to the selected text that is messing things up, but even if I select the text and just apply the ‘body’ preset to it it doesn’t view as it should.

It might be worthwhile to send a copy of the project to our support address so we can take a closer look at it, with instructions on which paragraph to make a preset from and which to apply the preset to in order to see these problems. I’m also not familiar with the Academic template, that must be a download from another user? If so there may be another vector for unknowns in that.