"Highlight current line" + disable blink = text invisible

Hi Keith and your ever-growing gang :slight_smile:

I’m having a problem with the “Highlight current line” setting. Here’s how it goes:

  1. Turn on “Highlight current line”. Start typing in document - behaviour as expected, current line highlighted, text visible.

  2. Next turn on “Use block insertion point” and leave default of 6 px. Now, when clicking into a line highlights it correctly, but then momentarily the text already on that line disappears… but then returns with the insertion point ‘blink’. Whilst typing, current text blinks in and out of visibility, in time with the insertion point blink.

  3. Then turn on “Disable insertion point blinking”. Now, when clicking into a line of text, the text becomes invisible, and typing produces invisible text. Of course, when moving onto another line, the text of the previous one becomes visible again.

Is this a bug, or is it user-error? I still have 1.54 installed alongside the NaNoWriMo 2010 version - have I created a conflict somewhere? I’m getting nothing Scrivener-related in my console log… (though interestingly other console messages indicate I’ve been bombarded with “Stealth mode connection attempts” unrelentingly for the last 5 hours. Ho hum.)

Best wishes, and much respect, thanks and love for what you are doing with 2.0 - I’m hooked already. And I thought Scrivener was near perfect to begin with. That’s why I do what I do, and leave the software programming to the experts!
Sarah :smiley:

Edit: I should mention I’m running Snow Leopard too, on an Intel MBP (with old-style silver keyboard).

Confirmed - I get nearly the same behaviour. In my case the text on the currently selected line disappears altogether regardless of whether the insert point is blinking or not. It’s obviously just a display issue as the text is obviously there when you move the highlight to another line.

At this end at least, it seems related to the selection of a block cursor, as with a non-block cursor everything works ok for me.

Well spotted :slight_smile:

(Mac Pro, OS X 10.6.4 here)

Eddy

PS: Let’s hope its not just a Sussex thing eh? :wink:

Yes, that’s exactly what I get and should have said - thanks for clarifying Eddy. I get up early (that’s my excuse anyway), so my brain is mildly befuddled by tea time and pretty much porridge by 9pm.

Don’t want to spook you out, but it could be more local than that - I work in Falmer.
Cue X-files theme tune?

Sarah

Thanks - added to the list for investigation for 2.0.1. There seem to be several bugs involving the “highlight current line” setting, so for now I would recommend turning it off and waiting for the bug fix.
Thanks again,
Keith