'Highlight current line' not working

I have enabled highlight current line - alas, it doesn’t. Have I overlooked something? The computer (OS Monterey) has also been restarted, the setting is there, I can see it when I open preferences, composition mode and check, but it doesn’t to what it is supposed to be doing. Any advice much appreciated.

You’d have to tell us more. Are you in page view (no highlighting available there, I think) or dark mode?

I have tried any and all of the modes, light, dark, themed. In all of them the highlight line is active but not working.
I keep thinking that I have probably set something incorrectly that is overriding the line highlight. I just can’t figure out what.



And I’m not sure what you mean with page mode. I’m writing the text the same way I always write, everything is the same - only the highlighting is no more.
It is so handy to have, that’s why I’m wondering if there is a way of getting it back. I have neither changed or updated/upgraded anything. It just disappeared. :slightly_frowning_face:

Page view.

Is the highlight function also misbehaving in other projects? In particular, check the Tutorial project, available from the Help menu.

I have not been writing in page view, I’m working in ‘flow text’ - I actually don’t know what the accurate term in English is, my apologies. It is an uninterrupted text.

Thanks for the great suggestion. Stands to reason that it should at least work in the ‘official’ document. I just checked it in the interactive tutorial. I clicked on highlighting current line, picked a colour and closed the set up screen. It isn’t working in the tutorial either, it seems to be turned off across all texts somehow although it is supposed to be activated. I’m really stumped.

Composition mode and the main editor have independent settings. Your screenshots are from the main editor, so please check the setting in the Scrivener → Preferences → Appearance → Main Editor pane.