Highlight does not function

Unable to select highlight after choosing text. The chosen text will not show up in highlighted color.
Windows 10 64 bit Scrivener 3, default theme. Had same issue on another computer, previously worked on this one.

Highlighting works fine, generally speaking. If you create a new text item in the binder, type in five words, select the middle two and highlight, does it not work?

If that works, then we’ll need more information about the conditions of the other case in order to reproduce it.

I believe it has to do with the options/appearance/main editor/ selection of background colors. When I attempt to change this, not sure which one of the choices, but I was able to remove the overall light blue tone behind all typed text.
At that point, your five word test worked just fine.
But, what do I set to remove all blue background from all text prior and future in order to have the highlight function properly?
I’m not sure which choice I changed, and went back to all of them default in order not to foul up any future writing.
Thank for your assistance as I set my options correctly! This default seems to go with the theme, on any computer I work on, so I need to repair it…

Attempted to change editor background color to white, which it shows in the menu as choice, clicked apply, but the change does not happen. It happened once by chance, but now I’m unable to make permanent and project wide change.

After much research in the user manual and online L&L tutorials, I finally realized I had inadvertently turned on “preserve formatting” on all the text I had and was inputting into the editor.
Operator Error…

1 Like

Thanks for the update! Hopefully at some point they can improve the signalling a bit better, so that text selection, text highlights, style highlights and preserve formatting can all be portrayed at once as a composite blending. This problem may still have been mysterious, but at least you’d have a good idea that it’s not highlight itself that is broken, but another kind of formatting being present “beneath” it.

[changed to new topic on “remove preserve formatting”]