Highlight shortcut not working

Cause I am a very amateur user of Scriv I use highlights to mark things for later.

Both the Format menu and the LHB mouse says Ctrl+Shift+H are a shortcut for HIGHLIGHT - well don’t work here :frowning:

Aloha Steve

Little bump - has this been noted or is it just me???

Try going to the Keyboard tab of Tools > Options and filtering for the Ctrl+Shift+H shortcut to see if there’s a conflict with another shortcut; you can then change one of them or choose “Scrivener” from the “Import” button menu to reset all the shortcuts to the defaults. Even if it isn’t listed as conflicted here, I’d try changing the Highlight shortcut to something else to see if that works, in case it’s a conflict with a more global shortcut from something else running on your machine.

stevehomer, I can confirm that I have the same problem (I never tried using the keyboard shortcut to highlight; thanks for the pointer). Following MM’s instructions, I find that Ctrl+Shift+H is assigned to both Highlight and Insert Image from File. I reassigned the latter to Ctrl+Alt+Shift+I (all the Ctrl+Shift combinations are taken), and Ctrl+Shift+H now works for highlighting. Plus the menu item Edit > Insert > Image from File now shows Ctrl+Alt+Shift+I!

MM, thanks, this is a great customization capability to know about. Perhaps the programmers might want to look into undoing the double assignment of Ctrl+Shift+H. Also, though Ctrl+Alt+Shift+I now shows up on the menu for inserting an image, it doesn’t actually do that. It just types an uppercase I. Same thing if I just use Ctrl+Alt+I, or any other combination; and it persists if I close and reopen Scrivener. There seems to be something disconnected there.

The Edit > Insert Image shortcut was changed to Ctrl+G,J at the time the Highlight command got the Ctrl+Shift+H shortcut, so it sounds like this is just a problem with the shortcuts not getting refreshed to the defaults. Selecting “Scrivener” from the Import button menu in the Keyboard options should correct it, resetting all the shortcuts to defaults.

Ctrl+Alt shortcuts typically don’t work, as this is a special combo that Windows often reads as the AltGr key; there’s not really anything we can do about that. It does unfortunately limit the modifier keys a good deal, hence Scrivener’s default shortcuts using a sequence like Ctrl+G,J for some of the commands in the fashion of Visual Studio and other shortcut-intensive programs.

OK, thanks. In the Keyboard options, I just clicked the Default button, and that did it. It goes to Ctrl+G,H though, rather than Ctrl+G,J. Anyway, it works.

The fact that stevehomer and I both got Insert Image onto Ctrl+Shift+H, though, suggests that this has somehow gotten encoded into distributions of the program, even though it’s not the default. I know I didn’t change it, since I didn’t even know how to change keyboard shortcuts before this.

It has to do with new shortcuts being added and some being changed in an update. When the program is updated via the auto-update, the new shortcuts were added to the list but not all the old ones changed because doing so would replace any customised shortcuts added by the user. I believe there was a note about this in the update file explaining how to reset the shortcuts to the new defaults. It’s only an issue using the auto-updater; a fresh install of course just sets all the defaults initially.

OK, thanks for the explanation. You mean I should … read the documentation? :open_mouth: :smiley: