Highlighting disappears in Scrivener

Hey guys, I’m a somewhat new user of Scrivener. Been using it for a few months now and most of the time, it’s worked great with no problems. However, somewhat recently, I’ve run into a weird problem where Scivener simply erases all of my highlighting. I am someone who loves to use copious amounts of highlighting to help me with my storywriting. I am making a visual novel so narrative choices pop up every now and then with dialogue specific to each choice, so I need a way to know which dialogue belongs to what, which is where highlighting comes in.

But like I said, the highlighting has disappeared randomly. I can make lots of highlighting using different colors, save AND backup my scrivener file yet it disappears if I close the Scrivener file and open it again. That’s it. The text appears as normal with the correct font and all but no highlighting. It’s really annoying having to rehighlight everything again and again only for it to disappear despite me saving.

I decided to let Scrivener stay open for almost a week now thinking that when I close the document and reopen it, the highlighting would disappear, but today I noticed the highlighting disappeared WHILE it was open. It must’ve happened when I closed my Macbook pro and opened it because last night the whole document was highlighted correctly and today it’s not. I opened up one of my many backups and they all open up with no highlighting, despite the fact that I know i saved while a lot of text was highlighted.

Anyone know abou tthis issue and how to fix it? I’ve used Srivener 2 AND 3 and still have this problem. Please, any help would be much appreciated.

1 Like

This certainly isn’t a typical result. I’ve used highlights for years in Scrivener and have never seen them vanish. There are a few things I would check to see what is going on:

  • Copy the text where highlights have vanished, and paste into another word processor like LibreOffice, Pages or Word (probably best not to use Nisus Writer Pro for this as it uses the same text engine we do). Are they visible there? If so we’re looking at a cosmetic bug.
  • Copy the text, create a new text item in the binder, and use the Edit ▸ Paste and Match Style command. This will strip all formatting out of the text, treating it as plain text. So the highlights will be gone—that’s fine, we’re looking to see if adding highlights to that copy of the text persist where others do not.

If they do—then my next question would be what the provenance of the original text was. Did it come from some other system entirely like Google Docs, originally? Another Web page? Another word processor? If so there might not be an easy fix. Gremlin formatting can creep in from other programs and make a mess at times, and often the only solution is something similar to the above: strip out all formatting to the bone and reapply any necessary formatting.

Thanks for all the help. I would like to say that all the text did, indeed, originate from Scrivener and not from any other source. Anything copied and pasted was not highlighted and I simply wrote in Scrivener from the beginning.I would also like to post an update in that I upgraded one of my macs, my iMac 2011 to High Sierra and thus installed Scrivener 3 for it. This was yesterday and since then, I decided to open up my Scrivener document (the same, exact one opened up on my macbook pro running Scrivener 2) straight from my Dropbox folder with the original document.

Scrivener 3 (S3) asked me to convert the old file format to a newer one that S3 is able to read (I didn’t know S3 was unable to read and edit legacy documents but had to convert them, first). Since I had done that, all of the highlighting magically reappeared! In fact, Remember when I said the highlighting was somehow erased in my last Scrivener document? Well, I had saved the document after that happening, so one would expect the highlighting to stay erased if I opened it again. Well, I opened that very same document in S3 and the highlighting returned.

I did not check on my Macbook Pro yet as, well… I’d be using the legacy file instead of this new S3 one and there would be no way to check what might be the problem, but this is very weird. I’ll certainly do the tips you mentioned as well but it’s so weird that after all the highlighting erased on my Scrivener document running S2, opening up that same document on S3 and converting it to the new file format changed everything. I didn’t even open up my backups but just used the original document.

As a final note, I had used S3 in the past but only the trial version as I had High Sierra for a while on my Macbook Pro but downgraded after noticing really bad battery issues. I don’t know why everything seems to be working well now, but I had stated how the highlighting was erased after some days of use and since it worked yesterday, I will be cautiously hopeful regarding if the highlighting stays after a week or so. Again, thanks for all the help.

Ah, the clarifications you posted might illuminate what was going on then. Some years back, Apple made a change to the text engine that broke highlighting across all software that uses its text engine. The symptom was much as you describe, with all highlights vanishing on any condition that would cause the file to be reloaded (which can include just leaving it alone for a while). It was never erasing highlighting, it was only not displaying highlights correctly—hence why loading the project in Scrivener 3 “magically” brought them back. They were always there, you just couldn’t see them.

What I would recommend is upgrading your copy of Scrivener to 2.9 (download page. It contains the patch that should fix this display bug.

By the way, Scrivener 3 runs on macOS 10.12 just fine. You don’t need to jump to 10.13 unless you really want to. That’s what I use—these days I don’t bother updating my main Mac until Apple basically stops working on it—usually sometime in the summer.

Thank you for the great advice! =)

I want to report that indeed, opening up Scrivener 2 on my Macbook Pro resulted in the highlighting still not showing for some reason. What’s even weirder is that some of the highlighting still showed but much of it did not. I’m sure the problem is still just as you described and I downloaded the 2.9 update.

I’d also like to note I would love to use Scrivener 3 but it requires OSX 12.1.0 and I guess I simply have OSX 12.0. I cannot find a 12.1 update on the Mac App Store and I’ll see if I can check Apple’s support pages but seeing as I already tried to downgrade from High Sierra before, I learned about how weird Apple is with their Sierra OS. In fact, it’s still called a beta while High Sierra is not. Sierra was only ever meant to be some sort of inbetween and you can’t even download it again unless you search online in Apple’s support pages. I might find OSX 12.1.0 but we’ll see. Thanks for all the help and I’m glad the mistake was mainly on Apple’s part with their text.

Yeah my notions of “just installing the older OS” might be a bit dated thanks to the Mac “App” Store. Don’t get me started on that. :slight_smile: