how correct in Portuguese language?

I set up the option “Correct spelling errors as you type”
but its not working.
I suspect that is configured to English language.

how I change for pt-br?

Someone more knowledgeable than I can pipe in here, but here is my opinion.

If you want to TEMPORARILY change the spell-check language, go to Edit > Spelling and Grammar > Show Spelling and Grammar. Then select either European or Brazilian Portuguese from the drop-down selections.

If you want to PERMANENTLY change the spell-check language, go to System Preferences > Language and Region. Then select Portuguese. Note: this setting is in macOS, not Scrivener.

You solved the riddle! thank you very much