How do I get centered chapters in my .mobi

Right, I’ll make this simple cos’ it’s really annoying me now.
I can’t seem to get the chapter names in my ebook to be in the middle of the page in the finished .mobi file. It’s fine in scrivener, but when I compile, the ToC, all the chapters and the title page are all on the left hand side in the kindle previewer.
How do I get it all centered?

How are your chapter titles entered? If they’re directly in the document text in Scrivener, my guess is that you’re overriding formatting during compile and all the text is going left-aligned, including the titles. You can fix this by deselecting “Override text and notes formatting” in compile, so that the compiled documents just use the editor formatting.

If the document titles are being added during compile, you’ll need to format them in the Formatting pane there. Click into the row at the top that you want to format, e.g. the Folder row, then in the preview area below, click into the sample title text and use the format bar to align it as you like. It will be handled separately from the main text and isn’t affected by the “Override text and notes formatting” checkbox setting, so you can leave that on if you had it set.

Thanks for that.
Yes, my chapter titles are in the document text. It worked anyway, so thanks for saving me time and annoyance.