How do I override body text format when compiling to PDF?

I want to change the style used in the ditor (Times New Roman, double-spaced, 12 pt) to Palatino, single-spaced, 11 pt when compiling to PDF. I don’t see how to override the default style ; it doesn’t appear in the list of styles used. I see my user-defined styles (e.g. ‘Verse’ or ‘Table text’) but not the default. The result is that my PDF is about 1000 pages long!

You would do this using Section Layouts when editing or creating a Compile Format. For each Section Layout, you can choose to override the text formatting and define the formatting you wish to use.

All the best,

Keith, that works for my user-defined styles but not for the unnamed default style, which is used for the main body text.

Defining the formatting in the Formatting tab for the Section Layout you’re using doesn’t work? Did you check the ‘override’ box at the bottom of the pane?


Overriding formatting in Section Layouts is exactly what you need, though - that does override the unnamed default style (“No Style”). Of course, you must also make sure that the Section Layout is being applied to the relevant sections of text (using “Assign Section Layouts”).

When I use the Scrivener paperback format, it sort-of works. But I can’t make sense of the settings. Export to Word and get a professional to do it!


It sounds like you’re not clear on how the various elements of the compilation process are supposed to work. Briefly, you should assign a Section Type to each element in the Binder, then in Compilation, choose a compilation format and assign a Section Layout to each Section Type. If the default compilation format doesn’t meet your needs, right-click on it and duplicate it then edit the errant Section Layout format till it does.

Have you looked at the Interactive Tutorial (on the Help menu)? It has a section which talks you through the basics of the compilation process. It won’t take long to read through and it may answer your questions.

But if you’re still having problems, list the precise steps you’ve taken and we’ll be able to help — at the moment it’s not really possible to tell at which stage of the process you’re having problems.



I think I see what has happened.

If you have not applied a defined style to some text in your project, then it will have the default text attributes, true, but it does not have a default style applied to it. In fact that text would have No Style assigned to it. So, in customizing your compile setting, the Styles-override sub-area is not the right place to set your desired text attributes for default body text.

Hope this helps – at least for the future!

I recommend going through the tutorial that comes with Scrivener, especially the section on Section Types and Compile. There’s no need to get a professional to do anything - you just need to learn how Compile works in Scrivener to get the most out of it.

All the best,

Thanks for the sympathetic tips, Brookter, Gr, KB. I have worked through the tutorial. I’ve also consulted the Handbook innumerable times. But the whole thing is too extensive and non-intuitive for me to take in and remember when I need it. Maybe it’s a sign I’m getting old! [I begin to sympathise with colleagues who tore their hair out misusing MS Word (which I know quite well) because there were too many options (and the menu layout kept changing). When a tool is a tool, and not one’s primary occupation, it should be simple.]

Scrivener is as simple as it can be to provide the features it does. See this blog post for some of the necessity of Scrivener’s Compile complexity, and how it was redesigned for 3.0 to alleviate some of the main problems users had with it in earlier versions: … ng-compile

If you want your MS to look different from the way it does in the editor, then there have to be a number of options to allow for this, and if you want full control over the structure of your MS in the binder, then Scrivener needs a system that allows you to tell it how each segment should be structure. There’s no solution to this that involves one-click-and-done.

The way formatting works is this, though:

  1. In the editor, most text has “No Style” - that is, no style associated with it. You can still format this text however you want; it just doesn’t have a semantic style associated with it such as “Block Quote” or “Heading”.

  2. Sections of text you want formatted differently from most can have a style applied - “Block Quote”, “Code Block”, “Heading” and so on.

  3. When you Compile, if you wish you can just keep all of the formatting exactly as it looks in the editor, or you can override it and have different formatting for different purposes.

  4. Section Types and Section Layouts allow you to tell Scrivener how to format different sections.

  5. You create and assign Section Types in the project. For instance, you might have a folder assigned as a “Chapter Group” and a text file assigned as a “Scene” (or anything else you want). Section Types tell Scrivener what each section in your project is.

  6. Each Compile Format has Section Layouts - for instance, a “Text Section”, a “Chapter Heading” and so on. Section Layouts each represent a different way of formatting a section.

  7. When compiling, you choose a Format and assign Section Layouts in that Format to Section Types in your project. For instance, “Use the ‘Text Section’ layout for all of my ‘Scene’ sections and the ‘Chapter Heading’ layout for all of my ‘Chapter Group’ folders.”

  8. A Section Layout can be set up to override the formatting of the styles in your project, and it can also be set up to override the formatting of all of the text that doesn’t have a style associated with it.

For instance:

  1. Click into some text in the editor. Ensure it is listed as “No Style” in the format bar.

  2. Open the Inspector, switch to the metadata pane, and make sure you know what Section Type the document is assigned.

  3. Go to File > Compile.

  4. Form the “+” button below the list of Formats, choose “New Format…”.

  5. In the “Section Layouts” pane of the Format editor, delete all of the Section Layouts and then add a new one entitled “My Layout”.

  6. Tick “Title” and “Text” in the checkboxes next to the Section Layout name.

  7. Tick “Override text and notes formatting” at the bottom. This tells Scrivener that any section associated with the “My Layout” Section Layout should have the body formatting changed.

  8. Click into the text in the formatting box area and change the font to, say, Courier.

  9. At the top of the title, change the “Section Title” text to bold and make it large.

  10. Click “Save”.

  11. Click on “Assign Section Layouts”.

  12. From the list on the left, choose whichever Section Type is associated with your text documents (the type you noted down in step (2)).

  13. Choose “My Section” on the right.

  14. Click “OK”.

  15. Now Compile.

You will see that the text you checked had “No Style” assigned in step (1) uses Courier in the exported document. This is because you used a Section Layout to override its formatting.