How do I stop Scrivener from autocorrecting...

Hi. How do I stop Scrivener from autocorrecting this:
post mortem
into this:
post Morten

The larger issue is… how to edit the autocorrection content?


I am new to scrivener, but I know how you can take away autocorrect because I had the same problem.
In Tools>Options, chose Corrections. There should be a box that says “Correct spelling errors as you type”. Uncheck it.

I don’t know how to edit the spelling list, but you can add words to your Personal Word List. Just press “View Personal Word List” in Corrections, and then click +. Now you can add “post mortem” or whatever word you want.

Hope that helps. Maybe someone who knows Scrivener can give a better response. :slight_smile:

I believe postmortem is either one word or hyphenated. Consequently Scrivener is trying to correct mortem as it isn’t being recognised as an individual word.

MertH - your helpful comment led me to discover that it’s “post-mortem” in British spelling, and “postmortem” in American spelling. And it comes from the Latin root “post mortem”.

Who’d have thought, eh? … ost-mortem … postmortem

yearling - thanks. As you say, how to edit the spelling list? That’s still the big overarching question here.


Back again but the news is NOT GOOD.

When I type the 2 words post mortem, Scrivener turns that into 2 words post Morten. So I select the 2 words post Morten with no trailing space, right click, choose Spelling, choose Spelling again, and I am presented with a box titled Spelling.

So far, so good. But it all goes downhill from here on.

The top box is blank but I imagine I am to write post Morten in there. Then I click on the Guess button and it offers me 4 choices, one of which is the one word postmortem. Not what I wanted but close enough - it will do - so I click on postmortem and then I click the Learn button. Nothing appears to happen, but hoping and believing all things, I close the Spelling box and in my document, I again type the 2 words post mortem, hoping that Scrivener will autocorrect it to the one word postmortem.

No such luck. It again gives me the 2 words post Morten.

Instead of swearing, I’ll simply say… HELP !!

As best I can tell, Scrivener spell checking/correction is word, rather than phrase, based. By default, appears it will accept “postmortem”, but will flag “mortem” when appears by itself or after a hyphen (as in “post-mortem”).

Quick fix is to right click on “mortem” and select Learn Spelling. Once you’ve done that, it will stop flagging “mortem”. But it won’t combine “post mortem” into “postmortem”. You’ll have to do that yourself, either at time of typing or later via a find/replace.

Out of curiosity, I fired up Word 2010 to see what it did. It did recognize/accept “mortem”, but did not flag or do anything with “post mortem”.

Scrivener spell checking appears to work off of two dictionaries.

The primary dictionary used depends on what platform you are on. Mac version uses OS X spelling dictionary. Windows uses Aspell dictionary. For more re Aspell, do a search of the forums for “Aspell”. It may be possible to update the Aspell dictionary, but looks pretty technical
viewtopic.php?f=30&t=25897&start=0&hilit=aspell )

The secondary dictionary is the Personal Word List, which can be updated via the Learn Spelling business above or via Tools > Options > Corrections > View Personal Word List. A workaround, for doing bulk updates of the list, is discussed in

Hope that helps.

SpringfieldMH, your educational post is indeed appreciated. I think I will just remember to type postmortem as one word. When other unexpected autocorrections will happen, I will try to use the same lateral thinking this adventure has prompted.

If you happen to know how to use the Learn Spelling procedure which I spectacularly failed to master (as per my post), I’d be glad to know.

It appears that the contextual menu that appears when one right clicks offers actions relative to different contexts… some relevant to whatever thing the mouse pointer is over/pointing at, some relevant to currently selected (highlighted) text, some relevant to the document one is currently in, etc…
While this may not be elegant or satisfy user interface purists, I assume it is there for pragmatic real world reasons… i.e. someone requested it/users continue to find it useful.

Spelling > Spelling, via the contextual menu that appears when you right click, is document oriented… not text selection oriented. It launches spell checking/review for all misspelled words in the current document, starting from the top. Not for the specific text that you may have currently selected.

By contrast, to individually deal with a specific misspelled word (marked with red squiggly), point at it, right click and the contextual menu will include best guesses as to the correct spelling, plus the choice of ignoring the word or learning (accepting) the word’s spelling.

Alternately, one can teach (add) words, as discussed earlier, via Tools > Options > Corrections > View Personal Word List or the bulk update method discussed earlier.

As best I can tell, all spellchecking in Scrivener deals with individual words, one at a time… not phrases. While automatic recognition and consolidation of a phrase such as “post mortem” to “postmortem” might be desirable, I see no indication of such being offered in Scrivener… or in Word for that matter (though I only tried it briefly in Word). The closest I can think of would be to go back later and do a find/replace of all “post mortem” with “postmortem” or “post-mortem”. I gather that some writers have a list of such problematic text that they routinely do this for during the editing phase.

See 15.2.2 Spell Checking in the manual (Help > Scrivener Manual).

Feel free to suggest changes/enhancements via the Wishlist subforum.

Hope that helps.

You can set up an “auto correct” for multiple word things like that by using the Substitutions

Tools | Options | Corrections | Edit Substitutions

For instance, I frequently mistype “in the” as “int he” so I set up a substitution to fix it for me.

Thanks for the educational reply, SpringfieldMH. Much appreciated, as I learn about this new tool.

SarsenLintel, I like the simplicity of your approach. I confess that I didnt notice the + sign at the bottom of the Substitutions panel. So thanks. I added my desired substitution… “post mortem” to “postmortem”. Only one snag after that – it didnt make the substitution when I tested it.

You have it working for your “int he” so I wonder what you did that I didnt think to do. Perhaps you’d have a moment to test out “post mortem” to “postmortem”?

Well, that’s a bit weird.

Scriv was autocorrecting “dont” to “Dont”, even midsentence, until I turned off the “Correct spelling errors as you type” on Tools > Options > Corrections.

Now it will happily give me the substitution I entered which is “dont” to “don’t”.

It also does the “post mortem” to “postmortem” correctly now. YIPPEE.

Not intuitively obvious to me, so hopefully this post will help some future sufferer.


Make sure you hit Apply (or OK) in the Tools | Options window - new substitutions don’t “take” until you’ve done that. Also, make sure the new substitution is checked in the Substitutions dialog (it should be by default).

Back in the Tools | Options dialog box make sure that Enable Additional Substitutions is checked as well.

And depending on how often you use that, you may need to enter it twice - once in a capitalized version as the substitutions are case sensitive.

All done and it appears to be working. Thanks again for taking the time to respond.