How to change and apply standard font to all documents?

I have a quick question about the editor in Scrivener.
I am a follower of the original idea of separating content and format, which means I don’t use styles and format my manuscripts with the compiler when outputting.
For typing, I have selected a “standard working font” in the editor’s settings, which I have always used.
Now the project has grown enormously, contains more than two thousand documents, and I would like to change the default font for all documents and apply it to them.
How can this be done?


Bildschirmfoto 2022-04-24 um 15.11.30

Well, first you’ve to change the editor font (in Scrivener preferences), then apply it via Documents → Convert → Text to Default Formatting…

From the Manual A.9 (macOS Scrivener): “Resets the text of the selected files and folders (or the text in the active editor session, including multiple documents in Scrivenings) to the default formatting used for new files. This default is established either globally in the Editing: Formatting preference pane (subsection B.3.2), or on a per-project basis in project settings (section C.5). You may also wish to read more about Resetting Formatting (subsection 15.5.5) in general.”

1 Like

Thank you very much for your quick answer. I am of course aware of this step, but since this project contains so many directories and documents, I was hoping for a simple “one-click solution”.
If there is no function to generally convert all the text contained in the project, then I guess I’ll have to take that step.

Read carefully: “Resets the text of the selected files and folders” or “the text in the active editor session, including multiple documents in Scrivenings

1 Like

It worked. I marked all the folders, but had to mark all the scrivenings again before it finally worked. Selecting the folders alone is not enough. Thanks for the tip. The problem is solved.

1 Like

You could select all the Binder documents, with or without scrivenings mode, and do the same thing.

No, unfortunately it doesn’t work like that. As I mentioned, I have an extremely large number of documents grouped in folders and subfolders that form my folder structure. Selecting only the top folder hierarchy and then converting it to the standard text does not work. However, if the scrivenings are displayed after a good minute and I select all the documents in them, then the conversion works without any problems.
In any event: The issue has been solved and I really do appreciate the kind feedback from all. Thank you.

I didn’t say anything about selecting the top folder, I said to select all the documents. Go to View-Outline-Expand all, click on the first document you want to convert, shift-click on the last, then do the conversion.

1 Like