How to change Default Main Text Attributes?

Hi,

I’ve been scratching my head for more than a year about it and still can’t make it out.

I’d like:

  1. the text I type to be aligned left by default WITHOUT the margin (please see attachment: “Good writers…” starts with a margin.

  2. each time I hit the Enter key in order to start a new line, I DO NOT NEED Scrivener to regard this as a new paragraph. In other words, if I need to start a new paragraph, I just hit Enter key twice. So, how to get rid of this unwanted automatic paragraphing my writing?

Note: I have noticed the Margins settings on the lower part of the Text Editing preferences but I dare not change them since they might be needed for printing purposes.

Please help. Thanks.

Well, actually, the reason why you keep getting a first-line indent is because you’ve never messed with the settings. :slight_smile: The screenshot you posted is of the setting that controls how new documents are formatted. So even though you correct the error on a new document, it won’t stick for the next, because Scrivener uses this setting to adjust how new documents are configured.

So by all means, tweak away and get things working the way you like in that box. That’s what it is there for. One other thing you might want to adjust, since you use double-spaced paragraphs like I do, is to remove any paragraph spacing from this setting box as well. By default there is a 1.2x line spacing combined with an 8pt paragraph spacing. I use no paragraph spacing at all (since I do that with the carriage return), but I do use a line spacing of 1.3x because I prefer the legibility of that setting. You can select one of the choices from that drop-down menu, or use Custom to bake your own.

Also note how I phrased things: this preference impacts new documents only, not existing ones. If you want to fix extant documents to conform to your preferred preferences, use the [b]Documents/Convert/Formatting to Default Text Style[/b] menu item. This can be done on many documents at once by selecting them in the Binder.

Now on the matter of printing, there are two different types of printing in Scrivener. Regular document printing from the File menu will print precisely what you see in the editor. So if you set things up to have no indent, that is how they will print. However that method is really just meant for quick proofs. The preferred way to print is to use Compile, which has its own text format override system. It’s a box that looks identical to this one in Preferences, that will change how the entire book looks if you choose to have it do so.

So you needn’t worry about how things look in Scrivener, if you want them to look another way when you print. You can have two different sets of appearance settings: one for working and one for printing and producing compiled final drafts.

Hi!

Both things you want are easy to do, and you’re in the right preference pane. I’ve included an image just to make the two bits you want clear.

So, for 1., assuming by margin you mean the first-line indent as shown in your screencap, all you need to do is drag the blue rectangle on the ruler there all the way to the left, as in the screenshot I’ve included. The margin control at the bottom that you mentioned controls the full margin on the editor window, so if you jump it to 60, for instance, you’ll see a lot more padding on the sides of your window. Feel free to play with it, since you can always save your settings before you do or revert to the default, and your settings here only affect what you see in the editor while typing, not what happens when you compile. The compile settings are all separate and you set them in the File>Compile Draft window.

  1. To adjust the space between paragraphs, you want the “spacing” dropdown menu. Select “other” and among your options on the new pane will be “paragraph.” Just set that to zero, before and after, and you’re golden.

margins.jpg

Hope that helps!

MM

Edit: Ioa beat me to it and explained it all much better. Which I guess is his job now. :wink: I forgot about just “print document” or exporting files. Never actually printed that way, hm.

Two help posts are always better than one. :slight_smile:

The one-off print feature is, as it stands right now, mostly inferior unless you just want to quickly print out a section of the book and take to it with a red pen. The feature will become more useful eventually, as it will better handle corkboard printing to Avery cards, and so on. For now though, in most cases using Compile print is the best method—if only just for the handy re-format feature.

Hi,

Yes, 2 posts are better than 1 and even so when both posts turn out to be EXTREMELY helpful :smiley:

I really want to thank you very much for the very detailed explanations and the very useful couple of tips you added.

I’m very happy: at last, I can use Scrivener the way I want :smiley: :smiley:
Result: I’m going to use it more and more (that means I’m gonna use less some other apps I used to export from to get my texts into Scrivener).

Thanks again!