How to change font size for titles in Kindle export

Hi,
New user here. I imported my book from Pages which went fine, and exported to Kindle but the book title page and chapter titles are all the same size as the regular text, when they are much larger in my original copy.

I created the whole thing as one file, not separate chapters in the binder (if that makes a difference for chapter headings).

How can I change the text size or set up H1 or H2 designations, if that’s what’s needed, to the ebook looks the same as my print version?

Thank you in advance for your help.

Hi,

The Kindle - as you note - relies on text being H1, H2 etc for titles. To set up your titles as headers, you will need to ensure that the titles are not part of the text in the editor but instead are added during Compile (by ticking “Title” in the “Formatting” pane of the Compile sheet). You can then set the titles to a header style like this:

Hope that helps.

All the best,
Keith

Thank you.
A couple of questions (because I tried what you said and it didn’t work for me).

Currently, my titles are at the top of each chapter, and I have two returns over each one. Should I delete the titles and instead upload each chapter separately into the binder, and title those the chapter names?

Sorry I’m dim on this.

thank you

Ah, right. The Kindle format does expect each chapter to be a separate file, so that its linking system (table of contents and so on) will work properly with it. So it would be better to break down the file into multiple chapters in the binder, yes. (And be sure to set up a “section break” between each one in the “Separators” pane of the Compile sheet. The titles should be in the binder and not part of the text itself. Also, when you set up the formatting in the Compile sheet, ensure you are formatting the correct row (the text document row for text documents, the folder row for your folders and so on).

Note that we have a video tutorial that covers setting up a project for Kindle and .epub export on our videos page which should help:

literatureandlatte.com/video.php

Hope that helps.

All the best,
Keith

Thank you for your help so far. I’ve looked at the videos, read what I could find, and am still messing things up. Here’s what I’m doing and the results.

I have the title, copyright, and dedication as the first file in the drafts folder. I inserted a “page break” after the title, after the copyright, and after the dedication.

Then I inserted each chapter as its own page in the drafts folder, as instructed (I hope). I couldn’t figure out how to put separators between the chapters, if that’s what you instructed in the prior post. I have page breaks at the end of each chapter, though, in the actual body of each chapter.

Now, here’s the results:

The first page, which should have the title in big letters, is coming out regular size. AND it has a big honking Untitled Document at the top of the page, when there should be NO title added.

My table of contents lists THREE Untitled Documents for some reasons. I don’t want ANY of the untitled docs listed. Chapters are the only thing which should be listed.

And none of the fonts are what I want. While I was able to change the chapter titles (thank you) via your prior post and selecting Header 1, the font is not what I want, nor is the body font of the book, even though it says Georgia in the actual file, it comes out something else when compiled.

I can’t figure out a way to adjust particular compile settings on a per document basis, it only seems to allow for the entire draft folder. Should each chapter be in its own folder? Is that the issue (other than my clear stupidity?)

Please help - my head is getting sore from all the bashing against the wall. :confused:

thank you.

All right…here goes. This is long so get a cup of tea before you start. :wink:

The formatting is set by document type and level. It sounds from your description like you just have a flat list of document files (no folders or document groups), so all of these will be formatted identically. If you want to change the formatting for some, you can move them to another level (e.g. create a folder and then put them into it). Knowing what you want to do with the formatting here would help a little in explaining how to go about this logically. I’ve explained in my answers below how to achieve the different results you’re after, based on the assumption that you’ve got just a list of single documents in the Binder, but let me know if you need more specific instructions for something.

Page breaks and separators can be added during compile by checking the “page break before” box in the Content pane and by choosing appropriate dividers in the Separators pane. In this case, choosing “section break” as the “text separator” will act the same as a page break, so you don’t need to add the breaks manually to your text at the end of each chapter or with the “page break before” option.

Kindle uses its own font, so it doesn’t matter what you put in. Generally when you compile you can choose to override the formatting (so that you can export with a different font than what you use when writing in Scrivener), but whether or not you select this for the Kindle doesn’t make a difference.

Since the Kindle relies on the header tags for the font size, you need to mark up your title with that style. There may be a better way, but here’s a method that works to get what you want (reference images below):

  1. Set the document title of your title page in the Binder to your novel title, as you want it to appear in the book, and remove the title and byline from the document itself.

  2. Create a folder in the Binder to act as a container for your title page, then drag the title page into it so it becomes a subdocument. This should now set the title page at a different level from the other documents in your Binder, so we can set the formatting differently.
    title page.png

  3. In the Contents pane of Compile, deselect “include in compile” for the container folder and, if it’s selected, deselect “compile as-is” for your title page.

  4. In the Formatting pane, add a new document level by selecting the row of the single text document that says Level 1+ and clicking the “+” button in the top right—you should get a row beneath it with the single-page icon and the wording “Level 2+” (the first row will have changed to just “Level 1”)

  5. Select the Level 2+ row and select the “title settings” button, then in the “suffix” area hit the return key (should give you the paragraph mark) and type the byline as you want it to appear. Click okay.

  6. Check the boxes to include the title and text for the document Level 2+ row.

  7. In the sample text area, format the title and byline with the header styles you want and center them if you like.

  8. If you want the title, etc. to appear midway down the page, increase the page padding. There’s no preview for this, since it’s meaningless in the sample, so you may have to play with this to get something you like in the actual Kindle; try starting at 16 lines (about 1/4 down the page) and work up from there.
    compile formatting.jpg

That will take care of this problem, also:

Since your title page was at the same level as the chapter documents, it was being formatted according to the same settings and so included the title. If you followed the above steps to change the formatting for the title page, this won’t be an issue anymore.

Since you’ve broken the title page into three pages with your line breaks (title page, dedication page, and copyright page), the Kindle’s table of contents is listing each page; because the title page document was untitled, all three come up as “Untitled Document.” (If you’ve made the changes above, they’ll now all come up as your novel title.)

If you want a TOC that doesn’t include the title page, the dedication, etc., you’ll need to make that page yourself instead of generating it automatically. To do this, create a new document at the top of your Binder and call it whatever you want your table of contents page called (e.g. something creative like “Contents”). For simplicity’s sake, lock the Editor (opt-cmd-L), then select all the chapter files in the Binder that you want in the TOC and drag them into the document, holding the option key. They’ll drop in as a list of Scrivener Links with the document titles.*

In the Compile settings, make sure that in HTML Options the box is checked to convert Scrivener Links to HTML, then in the E-Book Options select to generate the TOC and in the contents title put the name of your document (“Contents” in my example). This will cause that document to be used as the TOC and will thus only include the chapters you put there.

You can use this method even if you do want to include the title page, dedication page, etc. in the contents. Split them into separate documents in Scrivener, then copy them into the ToC document along with the chapters. You can edit any of the text there, so you can change your title page link text to say “title page” instead of the actual novel title.

If you split the documents, the dedication and copyright pages will now have their own titles, so to keep that title from appearing in the document itself when you compile, you will need to do one of three things:

  1. Select “compile as-is” for the dedication page and copyright page. “As-is” documents never include a title, regardless of other settings.

  2. Put these documents at a separate level from your chapters, like we did with the title page, above. These will need to be indented to level 3, so make make an additional container folder inside the first one and then move the dedication page and copyright page to that new folder. Be sure in the Compile settings in the Content pane to deselect that new folder from the “include” list.

  3. Change the document type: either convert these to folders or convert your chapter documents to folders.

For 2 and 3, adjust the settings in the compile formatting pane appropriately. For 2, you’ll add a new row to the single documents and then set that Level 3+ row to include only text. For 3, if your chapters are now folders, include the title and text for folders and don’t include the title for single documents at Level 1 (while your Level 2+ documents, ie. your title page, will still include title); if the dedication and copyright pages are folders, select to include only text for folders.

  • You can also do this with Edit>Copy Special>Copy Documents as ToC, but that will include page numbering which is meaningless on the Kindle, so you’d have to clean it up. Dragging is faster and gets you exactly what you want.

You.
Are.
Awesome.

Worked perfectly, and now I have a better understanding of the process.

Thank you VERY much for taking so much time to illustrate and explain the process. I appreciate your help more than a mere message can state.

thank you again.

Blimey, thanks MimeticMouton, for that incredibly thorough reply!

Excellent! Some of it’s just fiddly Kindle quirks, but knowing how Compile works helps you get creative with workarounds. :wink: Glad to have helped (and learned some stuff myself in the process). Best of luck with your book!

Suggestion: in the next Scrivener update, add Kindle Heading presets to the Scrivener toolbar.

  • Robert

That would be a little esoteric seeing as that is just one compile type, and titles can’t be formatted in the main editor anyway.