How to change layout compiling PDF for paperback

I’ve been frankly terrified to try and make sense of Compile even though I’ve used Scrivener for years, and every time I try and take a dive into it I feel like one of those monkeys scratching at the monolith in 2001: I pretty much can’t make heads or tails of it. But I can’t bear to spend all that money on some dedicated WYSIWYG software for outputting ebooks and PDFs and so I’ve decided to take the plunge.

And again I feel like a monkey.

I could just output a PDF for paperback format using one of the preset…things? But they aren’t quite right. I need a chapter number (‘1’, ‘2’, etc), centred at the top, with the name of the chapter below, like:


Chapter Title

But I can’t find any way to do that. I tried duplicating the 5.06 size PDF output in compile, but I can’t seem to edit the copy or if I can, it just goes horribly wrong.

How on Earth do I do this?


Hey @garygibsonsfwriter !

I can somehow understand your frustration. The compile settings aren’t easy to master. But after all, they have to serve a very broad user spectrum and fulfill a complex task. So, I don’t blame the developers for making them the way they did. It is a difficult subject.

Now to your problem. Try the following:

  1. Select the format of your choice in the left column of the compile dialog, right mouse-click and “Duplicate & Edit Format”. Now you have your own format that you can play with.

  2. In the dialog that pops up select “Section Layouts” in the left column.

  3. In the right column, pick the section layout that you want for your chapters, for example “Chapter with Title”.

  4. Now the part that you probably stumbled over: In the lower half of that right column select the tab “Title Options”. On that pane you find a box called “Title Prefix:” and that’s what you have to modify. You will probably see some text in there like:
    Chapter <$t:chapter><$rst_scene>
    That means: Print the word “Chapter”; then the chapter number as a word (“one”, “two”, …); and then reset the scene counter (in case your have scenes numbered).

  5. You don’t want your chapter number as words, but us numbers. So let’s change <$t:chapter> to <$n:chapter> and move it to the line before the word “Chapter”. The box should now read:

Chapter <$rst_scene>
  1. Go back to the “Formatting” tab. There you see that your changes have taken effect. Select the number, Chapter, and Section Title (that’s your chapter name!) and adjust them to your liking, for example with an indent and left-justified. Note that the dialog has a little bug: it does not always refresh and display your changes immediately. Switch back and forth between the “Title Options” and “Formatting” tabs and it will eventually update your preview correctly.

  2. Almost there: I see that you want to have your chapter name not a separate line, but behind the word “Chapter”. Go back to the “Title Options” tab and remove that paragraph mark behind the second line. That’s all.

  3. Change the name of your newly created compile format by editing the box at the very top. then aave your changed compile format by clicking the “Save” button.

  4. Don’t forget to assign your section to the section layout that you just modified. Otherwise your new chapter formatting will never show.

Once you understand the principle, compile will be de-mystified to you. Here are two more tips that might help you to understand the compile process:

  • Compile works file by file (or in Scrivener speak: section by section) through your draft folder. For each file it looks at the section type and tries to find the section layout that you have assigned to this section type. In the section layout if finds what to print (section title, meta data, section text, etc.), the format how to print it (indents, fonts, etc.), and a lot of options that you can associate with a section layout.
  • If you are looking for a table of all those “secret” $-placeholders, like $t, $n etc., click in the Scrivener main menu Help->List of all Placeholders…
    I hope that helps you getting things moving.

That’s both deeply comprehensive and absolutely great, thank you. I’m trying all this out now. I really appreciate your effort!