How to change Levels in Compile

Hi,

I have a section that is clearly beneath a folder (Level 2?), but it is showing up as Level 1 in compile. How do I get that section to compile as a Level 2?

I’ve attached an image to illustrate what I mean. The section is highlighted by Scrivener.

Thanks!

What do you have selected under “Contents”? If you have a collection selected, then everything will be treated as Level 1. Likewise, you have a subfolder selected for compile in “Contents”, then the “Compile Group Options” next to the subfolder selection pop-up will determine how the levels are treated. For instance, if you have it set up to treat a subfolder of the Draft as though it is the entire Draft, then documents immediately inside that subfolder will be treated as Level 1 documents, even though they are Level 2 in the Draft. So I’d need to see your “Contents” options to tell you more (including what is ticked in “Compile Group Options”).

All the best,
Keith

Hi Keith,

I had “Current Selection” selected as you suspected. When I changed the level to the Manuscript level and then selected what to include in the compile that way, the levels came out correct. Thanks.

To get more organized, I created a Front Matter group and included in it the title page, TOC, and Introduction. However, now the title page is getting the title “Title Page”, in addition to the <$projecttitle> tag that’s already in it. It wasn’t doing that before I put the title page into the Front Matter group.

How do I fix that?

Figured it out: Just needed to set Title Page to compile “As-Is”. Perfect.

Got another issue with levels, though: My first chapter ("… Difficult Question") is showing up as Chapter Two. There isn’t another file/folder preceding it at the same level, so I was expecting that it would show up as Chapter One.

It appears under “Part One: The Search…”

I attached a screen shot.

How do I fix that?
compile.png

What’s coming out as Chapter One? Is there anything in your front matter coming out with that numbering? Or could it be that you are using an auto-numbering tag somewhere before Chapter One?

It’s strange, but nothing is coming out as Chapter One. Nothing in my Front Matter is coming out with numbering.

In case this helps, what I’m trying to do is create a structure like the following:

PART I
Chapter One
Chapter Two
PART II
Chapter Three
Chapter Four

To keep me organized, I have my chapter files beneath their respective part folders.

Screen shot attached.

What auto-numbering tags are you using for Part 1 and Chapter One in the title prefix settings?

<$p>

It can’t be <$p> - that’s for page numbers and only ever works in the headers and footers (or in the main text if it has a Scrivener link associated with it).

I mean in the Compile panel’s Formatting > Section Layout > Title Suffix and Prefix settings area.

If you want, you could zip up the project and send it to us at mac.support AT literatureandlatte DOT com and we can take a look.

All the best,
Keith

Sorry, I was mistaken. The tag being used there is <$t>.

I emailed the project to that address. I made it a DropBox download because it’s fairly large due to imported PDFs.

Thanks for the project. Okay, this is an easy one, fortunately. The problem is that you have used the <$t> tag for both “Part” and “Chapter”. Every time the <$t> tag is encountered during the Compile process, it is incremented. This means that the following:

Part <$t>
Chapter <$t>
Chapter <$t>
Part <$t>
Chapter <$t>
Chapter <$t>

Will become:

Part One
Chapter Two
Chapter Three
Part Four
Chapter Five
Chapter Six

If you want to use the same numbering tag in this way, you need to tell Scrivener that it should be used in different streams. The way you do this is to assign it a unique name for each stream. So, in the title prefix for parts you would put <$t:part> and in the title prefix for chapters you would put <$:chapter> (you don’t have to use “part” and “chapter”, you could equally use <$t:foo> and <$t:bar> as long as the name used is different for each). This tells Scrivener that the parts should be numbered differently to chapters. So, this:

Part <$t:part>
Chapter <$t:chapter>
Chapter <$t:chapter>
Part <$t:part>
Chapter <$t:chapter>
Chapter <$t:chapter>

Becomes:

Part One
Chapter One
Chapter Two
Part Two
Chapter Three
Chapter Four

I hope that makes sense. More information about creating special numbering tags like this can be found in “Placeholder Tags List…” from the Help menu.

Hope that helps.

All the best,
Keith

That did it. Very neat. Thanks a lot, Keith!