How to change screenplay line type?

Half the time when I’m writing my screenplay format, and I press Enter to get to a new line, it doesn’t become the line type that I want it to be.
(mostly I’m alternating between Action, Character, and Dialogue)

I know pressing tab will change Action line to Character. But half the time, I want the line to be action, but it’s still a Dialogue.

What’s the keyboard shortcut for changing the line? A couple times I’ve accidentally pressed something, that makes a tiny menu come up that lets me push Down Up arrows to select the line type.

The problem most of the time is. I’m done writing a Dialogue line. I press Enter, and the next line is still a Dialogue type.

Also, sometimes at the bottom of Scrivener, it says if I press Enter it will change the new line to something (lets say Dialogue, because I just wrote a Character name)

BUT when I press Enter, it’s still a Character line. It doesn’t even change to what it says it’s going to change to.

You can manually change the current line to whatever you want, at all times, at the bottom right of the editor.
image
.
.

You may also edit the script itself, modifying the order of appearance of the elements.
Enter in an element → leads to this element
Tab → leads to – etc etc.

image

image

Enter - Enter (Enter on an empty line.)

You may use the mouse just as well.
. . . . . . . . . .

Since a dialogue is usually a couple of lines of back and forth replies, the Dialogue element is set to stick until you deliberately get out of it.

If you press tab in the character & dialogue, it’ll go from character to dialogue.
image
→ Here I typed “mike”, then tab. The semicolon was automatically inserted, and now I am writing whatever Mike says.
If you hit Tab once in the dialogue (where I am currently at – see my cursor?), it’ll take you to the next element. (Likely action.)

1 Like

Thank you I didn’t know you could edit that feature!

However, the feature just doesn’t work.

Half the time, the program says “If you press Enter the next line will be Action”
But then I press Enter and it’s another Dialogue line.

I noticed sometimes, I can backspace a couple times. Retype the period at the end of the sentence dialogue. Press Enter, and then it goes to a Action like it should, instead of a second Dialogue.

It just doesn’t make sense, it’s like the program makes next lines random half the time.

image

Are you sure you read it right? It is Tab you need to hit.
This adapts to the settings I showed you above. So I can’t think of how it’d tell you the wrong thing…

I would suggest turning on the View ▸ Text Editing ▸ Show Invisibles menu option temporarily, and examining the endings of your lines. You may see two different types of endings, a “down and left” arrow and a symbol. The latter is what you almost always want to see, and the former is what we refer to as a line break, or a way of cutting one paragraph into multiple visual lines. This will retain the current scripting element because you are still technically in the same line, and it can thus be useful when you do want a continuation.

My guess is that you are accidentally hitting the shortcut to insert a line break now and then, which would explain why it is sometimes sticking to dialogue. But if you see nothing but symbols, and observe it sticking to one element and are sure you aren’t accidentally keeping any other keys held down while pressing Return, maybe you’ve hit some kind of strange bug.

1 Like