How to compile a TOC PDF with title and page number on the same line?

The TOC looks fine on Scrivener (see screen shot attached)

However, when I compile to PDF the page number moves two lines below (see second screen shot attached)

Am I missing something?
Screenshot 2017-08-09 18.49.55.png
Screenshot 2017-08-09 18.50.41.png

Is there a reason why you’ve put the page numbers a half-inch in from the right margin?

The fundamental issue is that the text – title plus dots plus page number – is too big for the space available. You can either make the space bigger or the text smaller.


Hi Katherine,

initially, I used zero inch right margins and had the same issue.

I followed your suggestion and reduced the font to a very small size (8px). Same issue (see screen shot attached).

It’s plenty of space on the right. So I don’t understand why there is no space available.
Screenshot 2017-08-09 19.51.11.png
Screenshot 2017-08-09 19.51.20.png

The font size is irrelevant. The issue is the number of characters relative to the number of characters the line can accommodate. You’re still pushing the text out to the very edge of the line.

You might try using Page View in Scrivener to make sure you’re using the same size page in Scrivener as in your output document. Also check the Compile -> Page Settings pane for the same reason.


It works!!! :slight_smile:

I didn’t know about the “Page View”. Actually, I thought that the page was already in View Mode.

I own you one. Feel free to send me the link to your books and I’ll have a look / promote etc :smiley: