How to Create Nested Folders

Hi:

After using Scrivener for years and, at one time or another having consulted all the help functions available, I’ve frequently developed my own workarounds because I couldn’t figure out straightforward ways to do things. However, one item is very time-consuming and bothersome and I’ve lost my workaround so I finally decided to ask for assistance with it.

When I create a project, I make up a bunch of folders (my Chapters) that are on the same plane as Title Page. I do this by clicking Title Page and then control-N repeatedly. Somehow, in the murky past, I figured out – or stumbled upon is more likely – how to then create a subfolder of my chapters – a scene. However, along the way, I forgot how to do this and the only way I’ve been able to manage is to click on the one subfolder and then click control-N to make up a bunch of those subs, scenes to me but probably nested folders in the jargon. After that, I move some of those blank scenes under my chapters. When I need more scenes than I’ve created, say for a new chapter, I go to a previous chapter, click on a scene, control-N it and then move the newly created scene below the empty chapter. As you can imagine, this is VERY time-consuming. I can find references to nested folders in the help materials but nothing about actually creating them. From what I can figure out, the big green button only pertains to creating chapters.

Any help figuring this out and cutting out all this time-consuming maneuvering would be most appreciated.

Jane

Hi, skidawayme,

I’m not sure if I understand correctly your need, but Scrivener does not actually know about chapters or scenes, that’s just a useful logical distinction which is up to you to consider or implement within your project structure.

Scrivener does know about documents and folders, though. You can create a text document with Ctrl-N and a folder with Ctrl-Shift-N in Scrivener for Windows. Then you can drag the newly created item as you please.

You may also convert any document to a folder, or folder to a document as well, by right-clicking on it at the binder and selecting the corresponding option (it should be the one just above the last one).

Hope this helps!

Hi R6D2:

Thanks for the response. I tried your suggestions and am still having the same problem so I thought it might help to post the screen shot.

What I’m calling chapters are the purple folders. Beneath them are yellow and turquoise sub-folders. When I put my cursor on a purple folder and click control-N, the program creates another purple folder (actually, it’s not purple yet but it’s on the same level as the purples.) If I click Control Shift N, the same thing happens. What I’m looking for is a way to create the yellow and turquoise folders

Jane

Okay there are two ways around this. First of all, a little terminology. The documentation refers to these items as three different things:

  • Folder: the thing you get when you press Ctrl-Shift-N, with a blue icon. When you select these, Ctrl-N makes new items automatically indented beneath them. When you click on them, you get a “group view”, like Corkboard mode, instead of a text editor.
  • File: what you get when you press Ctrl-N, with a sheet of paper icon. You can never make a child directly beneath one of these, but you can always drag one in or use the Ctrl-RightArrow shortcut to indent an item beneath the one above it.
  • File group: what happens when you indent items beneath Files. This is what you have in your screenshot. Everything is files or file groups. You have no actual, what we would call, “folders” in this screenshot. File groups go on acting like files, even though they have stuff indented under them. If you click on them, you get a text editor not a group view. If you press Ctrl-N with them selected, items are not automatically indented.

So the most obvious solution is to actually use folders instead of file groups. Try right-clicking on “Day 2” and selecting Convert to Folder. The icon will change to the blue filing folder, and now when you select it and press Ctrl-N a new file will be indented beneath it, rather than alongside it.

The second option is to make file groups act like folders. You can do this in the Tools/Options… window, under “Navigation”. There is an option at the top to treat all documents with subdocuments as folders. You may have had that option chosen a while back, but it got reset in an update or something.

If all of this is still a mystery, I’d recommend reading the user manual’s introduction to how the binder and its items work. The good stuff starts in 8.1.2 on pg. 58. I’d read down to 8.2 at least (there is a table of all the icon types on the following page).

Hi Amber:

Will try out all of this. I did read that section of the manual you referenced but I think the problem was my not understanding the proper names of what I’m calling folders. I’m sure what you’ve suggested will work.

Thanks again,
Jane

Hi, skidawayme. I see now the source of the confusion. Labels (being Chapter, Scenes or whatever you name them), don’t confer the attribute of folder or document to any element in the binder. That’s what I meant when I mentioned they were just a useful logical distinction.

But AmberV put it all a lot more clearly stated.

Good luck on your story!

Very belatedly, thanks! The holidays caught up with me.

Jane