How to export as HTML sans <br/>

I am currently building a website from a Scrivener project that contains 580 documents, each document needing to be a web page. I nearly jumped for joy when I found out that I can export Scrivener documents as HTML. The problem is that the formatting is off in one significant way. I have the export settings such that it exports with no CSS, but this causes there to be a

in between paragraphs, which means all paragraphs are an extra space apart. If I can figure out how to export as HTML without the
, I will indeed jump for joy. Does anyone know how?


will only be exported if you actually have a blank line between paragraphs in the text, in which case the
is correct (and HTML export is actually handled by the Apple frameworks, so I can take no credit for that!). Do you really want a blank line between paragraphs in the editor? Usually it’s better not to have an extra return character between paragraphs, but instead to use paragraph spacing so that there is blank space between the paragraphs the same size as an extra line without there being an extra return character in there.

All the best,

Hi Keith,

Thanks for your reply. I think I understand what you’re saying, but not how to do it.

When I type a document, I write a paragraph, then press enter twice to start the next paragraph. Are you saying that this method creates the superfluous
? What is the proper way to do paragraph spacing?

Yes, hitting enter twice creates a superfluous

Use a single return to create a new paragraph. If you want more visual space between paragraphs, use the Format -> Text -> Line and Paragraph Spacing menu.


Hi Katherine,

Thanks for the explanation. Unfortunately that means my only options are to either go through every document and delete all the extra blank lines, or go through every html page and delete every
. Is there a faster way to do this? (I know that exporting with CSS would preserve the look I want, but it results in really ugly code.)

You can use Find and Replace to delete the extra lines. In each document, call up Find (cmd-F). In the “Find” field, hold down Option and hit return twice (holding down Option allows you to enter return characters rather than having return trigger the Find). In the “Replace” field hold down Option and enter a single return character. Then click “Replace All”.

Holy crapatola! You guys just saved me hours of tedium. I highlighted all of my 580 documents, clicked into the text field, “found” and “replaced” all the blank lines (then changed all quotes to straight, and adjusted the paragraph spacing), exported it all as html documents, and put them in my website folder, which means I stepped 95% closer to having my website ready practically instantly. Thank you so much!

Look out for things like triple returns. Repeating the search and replace for double returns should make sure that any inadvertent triples are found and removed. This is also true when looking for double spaces: run the search and replace twice or more until Scrivener says that the search term has not been found.

Another one to look for is:
[space] return

…which won’t, of course, be found by searching for return return only.

These things I have learnt from years of editing my own and other people’s files. Apologies if they are blindingly obvious. Just trying to help.