How to get compile styles working

I apply a Style to some text. Then I override that style in the Styles tab of compile, change text color, and define a custom css class name.

None of this is showing up in the epub3 output. Is this a bug, or am I missing some steps?

I basically did exactly as in youtube.com/watch?v=k0IObQ5tz5g but it’s not working for me.

Bump. Is this just not implemented yet on windows?

As per the beta 6 release notes, the compiler is not yet fully functional.

Styles still don’t seem to work in Compile to Word under Beta 13.

I use two styles: “Heading 1” and “Song” – most text is NoStyle.
My text sections are compiled with “Override text and notes formating” checked.
There are no styles listed in the Compile -> Styles pane.

According to the 3.0 manual, if I don’t list a style in the Style pane of the Compile settings, that style’s formatting should be protected. This is not happening for “Heading 1” or “Song” – they are begin formatted like all the NoStyle text.

Sorry for the delayed response. This should be fixed now. Are you still experiencing this problem?

Yes. Beta 16. Doesn’t matter what Compile options I use, or what I’ve got formatted in the document. Arial is what compiles to PDF. At least I think it’s Arial. What I have set is DejaVu Serif.

Compiling to .docx produces the correct output, or near enough I can work with it.