How to get Word Count to ignore Annotations?

Hi,

I’d like the Word Count to show the words that will be included in the final document (rather than any annotations I’ve made for myself).

I have unchecked - Projects/Project Statistics -> Options Tab -> Exclude Comments and annotations.

I have checked File/Compile - Footnotes/Comments - Remove Inline Annotations.

Yet the Word Count at the bottom of the editor still includes the Word Count of the Annotations.

To reproduce:

  1. Create a new document.
  2. Type some text.
  3. Highlight all text and select Format/Inline Annotation.
  4. Word Count should be zero, but shows the count of words in the Annotation.

Scrivener v1.9

I’ve tried searching the manual for Word Count, the forum FAQ and forum searches but have not been able to locate anything useful.

How do I get the editor Word Count to exclude Annotations?

Regards, John

Hm, why has this bug not been addressed in more than a year? :frowning: I’ve just started testing Scrivener but the first thing I realize is that the word count is wrong. Any chance this will be fixed? Or if it is not a bug, what are we doing wrong? :confused:

/Christoph

For an accurate wordcount use the project statistics and make sure that project statistics/ options has the exclude comments and annotations button unchecked. Tophee it is not useful screaming something is a bug and should be fixed after a year when clearly it is not. Better to not just play with Scrivener but do the tutorial and find out first.

I know a bit of drama can enliven an otherwise moribund forum, but I’m not sure it’s fair to accuse tophee of “screaming something is a bug” when he qualified his question by asking:

For me, this is a bug for others perhaps not.

I like to keep my Annotations (notes) inline so I can quickly reference them. This allows me to have notes on individual sentences, asking myself questions, explaining why a particular choice was made over another, that kind of thing. But I also need to hit a word count. Having to go into the menu to get a word count (and wait while it works it out) slows down my flow and gets me out of the head writing space.

As a workaround, I’ve been using the ‘Document Notes’ box. But this doesn’t allow me to make notes on the sentence level, so instead, I have to reference the sentence in the notes. For more complex projects, that I’m still ‘working out’, I’ll often have another document open to keep notes and track between the two.

It’s time-consuming to do these things. But I assume I’m in the minority which is why it hasn’t been addressed.

Not the end of the world! :smiley:

Regards, John

A bug is something that doesn’t always work the way the programmer expected it to, or some action that under certain circumstances produces a totally unexpected behaviour of the software. Not being able to do what you want with the software is not a bug. The software not behaving the way you want it to is not a bug.

What am I doing wrong? I, too, have checked PROJECT->STATISTICS->EXCLUDE COMMENTS AND ANNOTATIONS, but they are still added to that bottom number.

Inline annotations and footnotes have always had to count as part of the running total as you type, because the text editor would run into performance issues under certain circumstances (lots of words and annotations). Project statistics runs a compile in the background, using the current settings, to get a more accurate word count, so if you are stripping out annotations, they won’t increase the word count in that view.

The only way the developer has been able to exclude comments and footnotes from the running word count total is for you to use inspector comments and inspector footnotes. You can convert from one kind to the other and vice-versa, but do keep in mind that if you convert back and forth, you can’t maintain a mix of inline and inspector annotations/comments and footnotes.

If it’s a performance issue, give the user the option of toggling on or off. Some hardware can handle it, some not.

Or just recalculate during the pause, when Scrivener auto-saves (use a visual cue like dimmed text or a bullet next to the number to let the writer know the number isn’t accurate).

I’m also seeing the bug that mikecaputo clearly demonstrated based on photographic evidence. So why is it still not addressed? It has nothing to do with performance. The field “words” at the bottom does not display the same number (shows 9) as “Words” if you expand it (shows 4). That IS a bug, unless someone can convince me that “words” and “Words” are conceptually different things.