How to include act and scene numbers when compiling in US script format?

Searching the forum, I found the thread 'Not exporting Act & Scene numbers to Final Draft’ which distinguished between projects created in v2 and v3, which may be the cause of my issue. Unfortunately I couldn’t find the answer to there, though, so here goes:

I have a project created in v2. I am now working in v3 and wish to export this project to pdf. The only format that comes up under Compile is ‘Script or Screenplay’ and nowhere can I find an option to include act or scene numbers, All I have, in both Scriv and the complled pdf, is
ACT [N]
SCENE [N]
Is it possible to persuade Scrivener to add the correct act and scene numbers, or do I have to do this manually?

Also, Compile does not preserve the page breaks between the title page, characters page and setting page and it numbers these pages, so that instead of the script proper beginning on page 1 it begins on page 4. Nor does Compile start each new scene on a fresh page.

Thank you so much.