How to include annotations in compile

Trying to get annotations to be included in compile. I de-selected “remove annotations” in the compile settings but they are still omitted. I tried searching forums but didn’t see the answer. Using Scrivener 3.2.3 for Mac. Thank you

Am running the same vers of Scriv, but was not able to replicate the trouble you are seeing. What file format are you trying to compile to?

FWIW, how your inline annotations will get rendered depends on the file format you are compiling to. So, when I compile to pdf and leave annotations in, they appear inline as bracketed red text. If I compile to Word, they are treated as Comments – so a reference number appears in the text and the content of the annotation shows in the Comments pane.

I compile as an rtf which I’ve been doing to pretty it up in word before sending to reader/editor. I could try pdf. I may be able to do all the formatting /modifying of text for the reader in scrivener prior to compile. I can do this quickly in Word - although I have to redo it each time then…

Thanks for the quick and knowledgeable reply.

Comments should work fine in MS Word, it’s a bit puzzling that they don’t seem to be. One thing to be aware of with other text editors is whether they support comments at all—TextEdit, the macOS text editor that is set to the default program for .rtf files, is for example unable to view them (or footnotes, images and a few other things).

There are a few things you could try to double-check and see if they are really there or if it is an external software issue:

  • Drop the RTF file back into your binder. Scrivener supports comments on import of course, so if they are there, it should see them.
  • If you have another program you can use, like Pages (though you want to use DOCX for that), Nisus Writer Pro or LibreOffice, that would be a good way to check.
  • Also keep in mind that Scrivener supports two different comment types, unlike most programs. There are inline annotations and comments in the sidebar, and they can each be selectively removed when compiling. This gives you way of handling public vs internal notes to self, among other things. In short though, if you want them all make sure both checkboxes are disabled.

Lastly, with the RTF-based outputs, you do have a few options for how comments are exported. The default is indeed word processor compatible comments, but if you double-click on your compile Format, in the left sidebar, to edit it and go into the Footnotes & Comments section, you’ll find a dropdown at the bottom that lets you convert comments to different formats. The “Inline comments” setting is the most broadly compatible, as it simply inserts the text right into the paragraph using the marker settings below.

So one of those settings may be preferable to using PDF, i.e. you don’t need to switch to a more rigid format simply to get a different behaviour.

You solved it! Thank you for such clear instructions. It was the fix in the 2nd to last paragraph, changing the dropdown “Export comments and annotations as:” to “Inline comments.” I hadn’t thought to look at the settings for the format in the left sidebar.

In case you want to know more details, before I made this last change, the rtf file dropped into Scrivener still had the inline annotation missing. Also in Pages. I think it wasn’t exporting the inline annotation at all into the rtf. I’m not using inline comments at this point.

Strange that you aren’t getting them normally, though! If you’re okay with the different approach to printing them, then okay, but if you do want to figure out why it’s not working otherwise, we can do a little troubleshooting.

I saved the setting and can come back to my forum convos if I run into the problem again when using a different format. Note that when I tested it by exporting to pdf, and the option “Export comments and annotations as:” wasn’t there at all, so I couldn’t de-select it to test whether pdfs would still export inline annotations.

I’m happy to troubleshoot further but you may have better things to do.

1 Like