How to Open Scrivener in Full Screen Mode on MacOS?

Every time I quit Scrivener and re-open it in MacOS the window needs to be maximized again. I want the full screen mode to persist.

I have followed general online Mac guidance:

  1. Go System Settings > Desktop & Dock > Windows and Apps > Uncheck: Close Windows When Quitting and Application
  2. Quit Scrivener while still in Full Screen Mode
  3. When you re-open Scrivener, it should now open in full screen mode. *It does not.

Any suggestions?

Thanks.

Opening Scrivener in full screen mode under some versions of Mac OS triggers a Mac OS bug that causes Scrivener to crash. Therefore full screen mode is disabled at startup.

Thank you for this clear and definitive response. Is there a setting in a program file I could change to enable the full screen mode? This would allow me to determine if the bug effects my version of MacOS on my particular laptop. Thanks.

Sorry, no.

The problem is that it’s a pretty nasty crash to deal with. Once it starts happening, you have to manually delete the file that Scrivener uses to save interface settings in order to make it stop. It’s not hard, but it does require just the sort of digging that people don’t want to do while locked out of Scrivener. We helped a lot of very grumpy users before we made the setting non-persistent.

2 Likes