How to prevent Compile from converting "--" into "–"?

I’m trying to compile a bunch of documents into a text file. I’ve already created a new Format and ticked the box “convert ‘smart’ punctuation into ‘dumb’ punctuation”, but nothing has changed. The text appears as two hyphens within Scrivener, but in the output .txt file, it appears as either an en-dash or an em-dash.

How exactly do I disable this auto-conversion?

Check your replacements.

Both in your compile format and in the main compile panel (right column).
That’s more than likely where it happens.

The smart/dumb punctuation has nothing to do with this.

Ohh, I see! You’re right, there was a replacement in the main compile panel. I’ve disabled it now, and it’s working. Thanks for the tip.

2 Likes