How to stop highlighting

My first post to this forum. Brand new to learning Scrivener (Windows Version, newest version) though I purchased it years ago; I’ve finally begun writing with it. All of a sudden, everything I type in draft folder gets highlighted, and I don’t know how to stop the automatic highlighting. It must be something simple I’m overlooking. Help would be appreciated. Thanks.

Go to Tools > Options and in the Editor tab, click into the sample text to select it, then right-click the highlight button in the format bar and choose the remove highlight option in the upper left. That should fix the highlighting for any new documents, assuming the highlight had inadvertently been set here as part of the default formatting, but you’ll need to manually remove it from any existing documents. Just select the highlighted text and click the highlight button to toggle it off, if it’s the same color, or choose the remove highlight option as in the Options.

Thanks so much for pointing me in the right direction. The sample text was already selected when I opened Editor tab in Options. By repeatedly clicking on the sample selected text, it became unselected, then highlighted in the highlight color. I clicked again and it became unselected. Somehow that process turned off the automatic highlighting. I was never able to do things exactly as you prescribed, with there being no “remove highlight option in upper left” when I tried those moves. I was able to remove the automatically highlighted text by selecting the highlighted text, right clicking on selected text, clicking on “color,” and then clicking “remove color.” (I could find no “remove highlights” anywhere.) Our versions of Scrievner must somehow be different (or maybe my version is somehow corrupted after moving from XP to a new Win 7 PC and installing upgrades without ever uninstalling?) But thanks again for so promptly pointing me in the right direction. It saved my day.

Glad you got it sorted! I apologise for being a bit unclear in my description. In Scrivener 1.8, if you right-click or click-and-hold on the highlight button in the format bar, you’ll get a colour palette popover with a grid of colours to select. The upper left square is white with a red diagonal through it, which indicates “remove colour”. The Format > Font > Text Color menu and the right-click context menu both have a spelled-out “Remove Color” option which does the same thing.