How to update to later version

Hi, I run UBUNTU 12.04LTS 64-bit. I have scrivener 1.6.1.1 installed and am attempting scrivener 1.7.2.3. It gives the following message:
scrivener: 1.7.2.3 (Multi-Arch: no) is not co-installable with scrivener:i386 1.6.1.1 (Multi-Arch: no) which is currently installed
I’m not able to find a identified method for removing scrivener. I am an advanced user in terms of linux but this has stomped me. Can you advise me?

thegeekstuff.com/2010/06/ins … b-package/