How to use # as a text/section break

When I compile the manuscript, a # hashtag is not inserted between blank paragraphs, so, I’m doing something wrong.

I believe I am setup correctly: Compile > Separators > Text Separator > Custom > #

In the manuscript I have left a blank line between paragraphs. I have also tried inserting two blank lines. No joy either way. I am “printing” to PDF. In terms of the two paragraphs, they are in the same chapter, separated only due to a change in POV from one character to the next.

This technique is only going to work for those that separate each scene into their own files. In the Separators pane, beneath each type you’ll see a description of what it means, such as between adjacent text files (not paragraphs). If you’re typing whole chapters into files, it’ll be easiest to just type in the separator by hand as you write.

Ah, got it. Perhaps this should be added to the Wish List then?

Many thanks for your help!

When you compile, look into the Replacements pane. There you can replace a double paragraph return with paragraph-return # paragraph-return. This way you don’t have to insert the hashtags by hand, and can only insert them for certain kinds of compiles.

But this strategy only works if you are absolutely consistent in how you lay out your mss when writing - if you really do want to have the hashtag on every blank line. Remembering this can be a headache, so in general I agree with Ioa: insert the hashtag separators by hand as you write.

(Right now you might do a project replace to insert the hashtags in one blow, so that as you edit and revise you can delete any hashtags in places you don’t want them to be.)

  • asotir

The main reason I did not recommend trying Replacements is that as with search and replace, they operate strictly upon the characters of the document, they cannot inject formatting. So an empty line (literally, two carriage return characters) can be replaced with “#” but then you end up with a left-aligned hash mark—not the look they are going for I’m sure.

The only way to resolve that (since the replacement is wiping out everything carrying formatting) is to use a placeholder character and replace that instead of all the carriage returns—but then you don’t need a replacement any more. :slight_smile:

I don’t know, it seems pretty easy to hit the ‘#’ key while writing. I’m not sure what a feature could even do to make that easier.

Or just cut things into scenes, a PoV shift seems a good place to be doing that kind of thing.

That would probably be the easiest approach for now. Then click on the Draft folder, set the view mode to Scrivenings, and hit Cmd-F to find. Paste in ^#$ into the find field, set the “Find Options” drop-down to “Regular Expressions”, close the find window, and alternate between Cmd-G (find next) and [b]Shift-Cmd-[/b] (centre alignment). That approach also has you looking at each one of them, to make sure the search didn’t hit any false positives.

I appreciate all the help. Thank you for your time. As it has all become too complicated for this newby, I’m sticking with the simple advice: Type them in manually as I go. :smiley:

That’s basically what I do as well. :slight_smile: Though for opposite reasons, as my scenes are broken down into smaller files themselves, and so the Separators feature would insert too many breaks.