Howto disable Language from being exported to MMD/LaTeX


Scrivener 2.1 (14118) breaks the MultiMarkdown 3 workflow for me, because

a) Exported Multimarkdown files always include

Language: German

(it is desirable to have no metadata when using MultiMarkdown 3 if you want to generate a LaTeX-snippet)

and b) The first line of an exported .tex-file is always


(this has to be deleted by hand to make LaTeX typeset the file)

a) is undesirable in MultiMarkdown 3 because it makes it impossible to work with LaTeX snippets without postprocessing (see, section «“Complete” documents vs. “snippets”») and b) simply doesn’t create correct LaTeX-documents when using MultiMarkdown 3.

If there is no place in the settings I have missed, I consider this to be a bug. I haven’t tested with any other languages, but it would be nice if you could change Scrivener to allow exporting MultiMarkdown documents and «MultiMarkdown -> LaTeX» documents without any metadata.



Workaround: Setting the SmartyPants-Language to English in the export-settings of the preferences fixes both a) and b). Personally, I don’t think this setting is needed, since you can set the language and all other MultiMarkdown-metadata during the compile-phase (or as a separate scrivening at the beginning of the document), which is more transparent.

I think this might actually just be an MMD2/3 thing. The meta-data key for language is now “Quotes Language”, and that can be safely used in snippets mode, it is one of the few meta-data keys that will not trigger full document creation.

As pointed out, for now you can set the system to English to omit any output, but you might want to set the Quotes Language key by hand in your meta-data in order to get the new MMD3 typography stuff working right. There are two values for German: ‘german’, and ‘germanguillemets’.