Hyperlink bug - Win10. Scrivener V3.1.5.1 64-bit

For Facebook pinned post on my wall, I created a Scrivener document in Urdu.
The document was to keep track of my posts. Names in Urdu, hyperlink in English as provided by Facebook.
For each post on Facebook, I created an item in the list in document, YYYYMMDD date, post topic all in black text. On next line I pasted the link copied from Facebook. It turns blue. Tested it. Link worked at that time.
Kept on creating other items in similar fashion.
Later on, created another item and link. Saved document. Went away or shut down computer.
When I opened my document next time. All items had turnmed blue with hyperlinks attached!!
But the real issue is that hovering mouse over real hyperlink (as previously typed), displays the recent and wrong hyperlink. Clicking on takes me to facebook but instead of displaying my original post, it takes me to the recent (wrong) post.
Last posted link item.
Hyperlink_As_Is_tooltip

Note all items turning blue with wrong tooltip and link…
Hyperlink_Wrong_tooltip
Hyperlink_All items turned blue with wrong_hyperlink and_tooltip

Hyperlink corrected manually by copying typed link then editing hyperlink
Hyperlink_tooltip_corrected_manually

What is going on?
To correct I have to go through hundreds of items… Tried. Worked. Then failed again.