Hyperlink formatting disappears upon export to Word

I’m having a problem with web hyperlink formatting disappearing when I export something to Word. The hyperlink is still there, but the text is formatted as regular body text rather than the standard default of underlined blue.

For a lot of my work it’s important that the person receiving the Word doc can see that there’s a hyperlink there, so I end up having to go through the Word doc and change every hyperlinked text format manually, which takes a lot of time. Any idea how to fix this?

I’m using Scrivener 2.6 and the most up-to-date version of Word for Mac 2011.

This prior discussion should help you out. The first hint to check Transformations is probably not relevant to you, since you indicate the links are there, they are just black and thus hard to find.

Hi AmberV,

Thanks for the response.

I’ve checked that panel. My version has no option for “Ensure hyperlinks are colored and underlined.” It only has options to remove hyperlinks, text coloring and underlines, which in my case are NOT checked. So my thinking is that those should be intact (or, technically, “transformed”) during the conversion to Word. But that is not happening.

:frowning:

There are two panels to check, as I mentioned you do not need to worry with the Transformations panel, since you do have links. You would need to check there if you just didn’t have links at all, to make sure the checkbox to strip them out was disabled. The other panel is RTF Compatibility.

OK, mystery solved, I think. AmberV, thanks for pointing me in the right direction on this.

I will leave an explanation here for others having this problem because there are some nuances that are not obvious.

• The RTF Compatibility panel is not visible at all until you select “RTF - Word compatible” or “Microsoft Word 1997-2004” or “Microsoft Word (.docx)” options in the “Compile for” drop-down.
• The checkbox for hyperlinks only exists in the “RTF - Word compatible” RTF Compatibility panel. I.e., if you’re thinking to yourself that since you want a Word doc you should choose that in your Compile For dropdown, you’re going to be confused.
• If you don’t Compile but instead Export (which I often do because I often simply want one or a series of Word documents, not a book or some other heavily formatted document), you never see any of these panels, and the hyperlink coloring and underlining are lost without explanation.

Here’s the workflow to get visible hyperlinks into Word documents:

  1. Use Compile, not Export.
  2. Select “RTF” as your output file type, and then check the box for underlined/colored hyperlinnks in the RTF Compatibility pane.
  3. Compile to an RTF file, not a Word file directly. OR select the RTF file export option, check the box to make hyperlink underlining/colors visible, and then switch to Word for your export option.
  4. If you’ve chosen to export to an RTF file, open it in Word and re-save it as a Word file to get the final file type.

I hope that at some point the L&L crew make this more intuitive.