Hyperlink Formatting Not Displaying

Greetings community,

I’m unable to see the default blue formatting when I insert an external hyperlink. It remains the standard black colour, although when I hover my mouse over the linked word/phrase, the hyperlinked “hand” appears. So the link is there.

I have checked the appearance preferences and they are set to the standard blue. [Menu – Scrivener – Preferences – Appearance – Textual Marks – Links – Use Default Colour]. I am however, able to copy and paste text from another program and the links carry across with blue, underlined formatting.

I’m using MacOSX 11.0.1, Scrivener 3.2.3.

Hope there’s someone who can help.

What do these links look like? The text of the link you insert? Perhaps Scrivener doesn’t recognise the text as a link?

Are these two separate issues being described?

  • Inserting a hyperlink: using the Edit ▸ Add Link... command.
  • Pasting hyperlinks from somewhere (it would help to know from what).

Thank you for your responses. My apologies for not being clear.

My issue is with the way an inserted hyperlink is displayed. (Or rather not displayed).

So, I go to Edit – Add Link, paste URL (or Command K). The link is successfully inserted. But the displayed formatting does not change to show there’s a link there. The word or phrase which is linked remains the standard black font, although when I hover my mouse over it, I see the hyperlink hand symbol and can click the link to open the page. The link is working, but the display is not.

Interestingly, when I copy and paste a linked word or sentence from another program, the linked formatting does carry through. So it’s only when I insert the link internally, within Scrivener that the formatting is not displaying.

As I mentioned above, I have checked the appearance preferences and they are set to the standard blue. [Menu – Scrivener – Preferences – Appearance – Textual Marks – Links – Use Default Colour].

I hope that is clearer.

Many thanks for any thoughts and suggestions you might have.

1 Like

I think I might know what is going on. Try this command: View ▸ Text Editing ▸ Show Markup. That will hide links that do not have extra formatting on them, which might explain why some pasted links look a certain way. Normally you wouldn’t see that formatting because your settings will override that appearance.

AmberV, you are such a gem. Thank you. That has solved my problem. Such a simple fix. Very much appreciated.