I AM NOT TRYING TO WRITE A SCREENPLAY

UPDATE #2: Nope. Now it’s going back to automatically putting me into screenplay mode for some reason when I switch to different or new windows. Its like it’s decided that this is the default mode, but I’ve checked in my preferences and this is not a default mode I have ever specified. This might need to get moved into the bug reports section.

UPDATE #1: I figured this out. But I’m going to leave this embarassing post up here in case anyone else runs into this problem, too. The moral of the story is DON’T SOMEHOW MYSTERIOUSLY ACCIDENTALLY HIT CTRL+8. Solution attached. I still have no idea how I managed to get the document into scriptwriting mode but there ya go.

This keeps popping up all of a sudden every time I hit the return key twice to go down a paragraph. WTF?? This just started happening today. It is literally preventing me from creating paragraph spacing. I have to manually select “General Text” every single time I want to go down a paragraph. Otherwise it asks me what kind of screenplay formatting I want. I was literally using Scrivener yesterday and this wasn’t happening. I can’t for the life of me figure out how to disable it. It’s also inconsistent- sometimes the items on the menu are different. It’s driving me insane. I tried clearing the formatting, tried upgrading and restarting and clearing the formatting again, and I never added any special stylings to the document in the first place, and even if I did this shouldn’t be happening.

Mac Os Sierra. Not high sierra. Scrivener 3.1.1.

EDIT: now it’s only showing me screenplay style options on the dropdown. It’s also happening every time I hit the return key.

Screen Shot 2019-01-08 at 1.57.41 PM.png
Screen Shot 2019-01-08 at 12.36.01 PM.png

When you press ⌘8, not only will there be a message that flashes up on the screen to let you know you’ve entered (or left) scriptwriting mode, the icon of the document you have toggled will turn yellow. This indicates it is a script file now, and will go on using scriptwriting conventions until you toggle it back off and the icon is white.

The important implication here is that scriptwriting isn’t a global mode that Scrivener either is set to use or not, it is not even a project setting—it’s a type of document. The shortcut changes the type of document, much like Documents ▸ Convert ▸ to Folder changes a file into a folder.

Furthermore, Scrivener attempts to provide consistency in that if you are writing in a scriptwriting file and make a new file, the new file will be a scripting document as well. So until you clear out all of the yellow icons with ⌘8, you may continue to see new scriptwriting files, or suddenly find yourself in scriptwriting mode when switching from one area of the draft to another.

  • I don’t actually ever remember hitting ctrl +8
  • and if I did, there certainly was never a message that flashed up on the screen letting me know about it
  • and no document icons ever turned yellow,
  • yet script mode was still on for some reason, and was mysteriously applied to every document I’ve brought up so far that I haven’t already manually switched back to the mode I had it in before this mysterious switch happened.

I don’t know if you’re a user or a moderator but if you have a sec, could you show me what yellow icons you’re talking about?

Hi m1rrag,

He’s referring to the document icons in the binder. Documents in scriptwriting mode have their own special binder icon. Have a look at Table 7.1 in the Scrivener Manual for a visual.

Best,
Jim

Yeah I definitely didn’t see any icons change. Hopefully the Scrivener folks get around to seeing this as it appears to be a bug.

Scrivener running on two different Macs and not getting this issue. What are the specifics of your machine?
If the majority of people are not having this issue it lessens the chance of a bug and makes one wonder about environment and settings