I can't compile documents anymore

Hello, everyone!
Each time I try to compile a document Scrivener breaks down … :cry:
Is it possible that my project has become too big for my laptop. (The laptop is now one year old …)
I must admit that I’m working on a novel that comprises 5 volumes. I’m only just starting volume 3 … But I can’t even compile one single document without Scrivener crashing.
I’ve tried another project with fewer documents in it and it worked …
Is there anything I can do? Do I have to break down the project into several ones? (I wouldn’t like that very much because I use a lot of links between documents.


What version of Scrivener are you running? You can find your version number by going to Help → About Scrivener. I would check for updates, while you’re there.

How large is the project that you’re unable to compile? If you look at it in File Explorer, what’s the size listed there?

You could do a test and create a new project, drag volume 1 of the novel into a new project, and try compiling that. Does it run through? If not, there might be something corrupted in the file itself. If so, add volume 2. Are you still able to compile? It may be, adding everything into a new project shakes loose the issue. Or, you find where the limit is for when the Compiler stops working.

Hello, @JenT,
I’m running Scrivener and Scrivener says that it’s the latest version available.
The whole folder has got 73.5 MB and the scriv-file has got 1.14 MB. I’ve stored only a couple of web pages for research. But I have got about 100 character sheets with at least one photo each and there are a lot of links between the files. I don’t know what makes the project so big. A couple of weeks ago I had also stored all my handwritten notes as pdfs, but that was definitely too much because Scrivener needed at least 15 minutes for the backup when I closed it. I’ve typed all my handwritten notes now, so the files aren’t that big anymore.
I’ve tried to drag one volume into another project and it works. I can compile it now. It also works when I drag two volumes into the new project. I can’t say much about the other three because most of the files are still empty. I haven’t planned them yet.
But after dragging the two volumes into another project my internal links have become external ones now because they refer to the old project. But it’s a relief to see that I can still compile documents.
For the time being, I think I’ll leave everything in the old project and continue planning and writing. Once I want to compile the first volume I can open a new project. For my planning it’s important to have everything in one project to be able to create as many links between the scenes and the character sheets as I need.
At least the compiling failure it’s not a Scrivener problem. Probably the file really is too big.
I guess I’ll just write the first draft in Scrivener and then move the whole text to another programme which has got German spell checking and German style analysis and German readability evaluation and so on. Scrivener is perfect for me concerning the planning process but it wasn’t made for writing in German. (Let’s hope for the best in the future … :slight_smile: )