i.e.

Searched the forum but could not find an answer.
Does anyone know how to use the term i.e. (id est) in Scrivener without automatically capitalizing the “i.” Whenever I use it, Scrivener thinks I am starting a new sentence.
Sorry if this has been answered already.

Don’t know the answer to this, but wondered if the same problem happens in other programs?

If no one comes up with a Scrivener-based answer, then as a workaround could you go into System Preferences/Language & Text and in the autocorrect section set up an entry that turns I.e. into i.e.?

It’s the auto-capitalization of the personal pronoun setting that is doing this. If you turn this off in Scrivener->Preferences->Corrections, then the ‘i’ won’t capitalize automatically.

FYI, I tried my suggestion above and it worked. Did need to make sure Scrivener was closed and then reopened after the change had been made in sys prefs.

This way you can leave the “i” capitalisation that @robertdguthrie mentioned so that Scrivener will still autocorrect the personal pronoun, but force the system to “correct” I.e. to i.e.

Even quicker: set up a replacement so “ie” becomes “i.e.” - this saves two keystrokes and I can’t think of any time you would want to write “ie” as a word.

  • asotir

I really wish I had thought of that. Doh!

Good idea, asotir. One thing you might want to fiddle with is adding a space at the end. The reason being is that when Scrivener encounters a period, it will auto-capitalize the next word as if it were a new sentence (unless you turn that feature off). If it auto-expands to something that ends in a space, it should’t trigger the auto-capitalization (I think).

To R Guthrie, you are right, auto-replacing “ie” with “i.e.” forces capitalization of the next word - but not only that, using the replacement string "i.e. " ALSO forces capitalization on the next word. And auto-replacing “I.e.” with “i.e.” forces the capitalization on the next word as well.

Is there no way around this other than turning off auto-capitalizing “I”?

  • asotir

The only other option is to tolerate oddly capitalized instances of “i.e.” while it’s in scrivener and turn off “Fix capitalization of sentences” under the preferences Corrections tab.

You can then set up your compile Replacements tab to replace any instance of “i.e.” with “i.e.” (leave the setting for case sensitivity off).

Abbreviations are highly difficult to program around, and Apple apparently didn’t bother to with their supplied text engine.

Great tip; I’ve been struggling with these “I.e.” sorts since the '90es when auto-corrects started to be implemented.
Typing “ie” then cmd-F to find “ie” & replace with “i.e.” works very well.
If done after the the next word has been typed with a space or punctuation mark after it, it does not force capitalization of the next word; however, it will find “ie” in, for instance: lies…

After i.e. it will capitalise the first letter of the next word whether i.e. is typed as an autocorrect or typed in full. The autocorrect is easy (ie to i.e.) and the next letter capitalisation can be undone by cmd+z. Not ideal…

Shouldn’t do if you search for whole words or "ie " (with a space after it).

I’m really off my game, should have noted this before… If you leave it “ie” or some variation thereof in your text, then the Replacements tab in compile can match any capitalization of that as a “whole word”, and replace it with i.e. without any fuss over the next word.