I get this error message when I save....

I get this error message when I save (or the program auto-saves):

Not all recent edits could be saved. Files that could be recovered have been saved to /Users/raylej/Documents/Public Education Without Purpose-6.scriv Recovered. The project will now close.

I’ve checked the folder permissions, and I’m set for ‘Read and Write.’ I have several free gigabytes of space available. I get this message regardless of whether I’m trying to save the file on my main drive, or my external drive.

The Deadline Cometh! Help!

Thanks.

Joseph Rayle

HI Joseph,

This error message comes up when OS X refuses to accept the save from Scrivener for some reason, which makes it a little difficult to tell the exact reason, although it’s very rare (not that this is much comfort to you of course). Could you please tell me the location you are trying to save to? Is it on removable media or an external drive or suchlike, or an external server? I’m wondering if, even though the file is set to read/write, there’s some other permissions error along the way. What happens if you try to create or save another file in the same folder, from Scrivener and from a different program?

Thanks,
Keith

Keith-

I am using an external drive, connected with FireWire. I successfully used Word to save a file to the same directory to which I’ve been saving my Scrivener stuff, so I don’t think it is an issue of permissions. I’ve tried saving my Scrivener file to several other places, including my startup disk, and the applications folder that contains Scrivener. Finally, I double-checked the permission setting on the file itself, and it is set for ‘read & write.’ The short answer here is that I get the error message regardless of where I save my file. I’m pretty sure this started happening after I downloaded the latest update (not that I necessarily believe these things are related-I’m just supplying all the information I can).

Thanks. I hear the wolves howling in the distance…

Joseph

Just to complicate things: I opened a new project in Scrivener that I am able to save without difficulty.

I am old enough to remember life without computers, and romantic enough to believe I was happier then.

Thanks.

Joseph

Actually, one thing to check is that permissions are set for the whole file - a .scriv file is a package, so it could be that a file inside it doesn’t have the right permissions. Try the following:

  1. Get Info on the problematic file in the Finder.

  2. Get rid of the “.scriv” extension. When you do this, the icon for the file should turn into a regular OS X folder.

  3. Unlock the permissions with your admin password by clicking on the lock at the bottom of the Get Info window.

  4. Select “Read only” and then set it back to “Read & Write”.

  5. Click on the gear button at the bottom of the Get Info window and select “Apply to Enclosed Items…”, then confirm the change.

  6. Add the “.scriv” extension back to the file.

Now try opening it and see if it will save.

Glad the wolves aren’t at the door just yet…

All the best,
Keith

All right, I think I’ve got it sorted. Thanks for your prompt help.

(We now return you to the regularly scheduled panic, already in progress).

Thanks.

Joseph

Great! Glad that helped.
All the best,
Keith

Hey Keith,

I’m getting the same thing. I’ve tried the above instructions, and it’s not working. I still get the same error message. I can save a new project, but can’t save edits on existing ones.

Problem started when Time Machine failed and I had to bring back my entire documents folder manually. I’ve checked permissions, and they look okay. Any other suggestions? It affects every Scrivener file I have :frowning:

  • Michelle

…aaaaand found the problem. For whatever reason Everyone kept bouncing around to Custom for access. Weird.

Fixed now. Thanks so much.