I need some with with formatting...

Hi folks,

so a few days ago I bought Scrivener, it’s a great program. I encountered a problem though and it’s making me go crazy: I’m in the editor mode and have set all my preferred indents (first line, left, right) via the ‘Tabs and Indents…’ option. Now I’m swithing to page view (A4) and of course there are different indents. No problem, I set them so that I can write from the left margin to the right margin, like you would in your typical Word/Pages document. But surprise! Now, when I’m switching back into editor mode, all my indents I previously made are screwed up! When I change them back and switch back into page view they are again screwed up there too!

Some pictures for better understanding:

  1. Set preferred indents in editor: i.imgur.com/X9rM5n3.png

  2. Page view indents get screwed up: i.imgur.com/8NcUs4P.png

  3. Set preferred indents in page view: i.imgur.com/1JbHAU3.png

  4. Editor indents get screwed up: i.imgur.com/QyMDA37.png

Isn’t it possible to have seperate preferences in the format ruler for editor and page view?

I really tried everything. I hope you can help me. Thanks.

Welcome to Scrivener!

I’m not seeing any kind of malfunction in your screenshots. In the first I see you’ve set a first-line indent to an extremely generous 3cm or so, and then a block left indent of about 2.5cm away from the margin (is that really what you want? The whole page indented 2.5cm in addition to the ~2cm margin? I suspect not, since you’ve dragged everything back to a more normal level in Page View). So yes, once you switch to Page View, where your margins are drawn in the editor, these values are going to shift over by whatever margin settings you have applied in the File/Page Setup… palette, under Scrivener options. In this case it looks like you have about a 2cm margin, pushing your indents to 5cm and 4.5cm.

By the way, if you haven’t done so already, it might be worth going through the Interactive Tutorial from the Help menu. This program isn’t very much like Word or similar programs. It’s not WYSIWYG, which I think might be a source of some of the confusion here—i.e. you’re using the indent markers like one might use the margin markers in a program that uses a desktop publishing approach. Scrivener on the other hand has very little concept of a page (Page View simulates the look, but it’s to be honest meant to be an aesthetic option, not something to use for page layout) and can produce text radically unlike whatever formatting you use while writing. The idea being: if one hates 12pt TNR but has to submit that way, they needn’t spend 12 months staring at 12pt TNR double-spaced. They can use whatever font size, whatever line height, whatever paragraph settings they prefer. When compiling the document out then stuff like margins and proper indents come into play.

Hopefully that sheds a little light. Think of the editor as being more like how writing a response on this forum works. You type into a white box and click submit—the result is some text that doesn’t look very much like what you typed in. Scrivener is similar to that concept in that using Compile takes the text you’ve typed “into boxes” and turns it into a formatted document of some type.

Thank you for your reply! By the way this is not my native language so excuse any mistakes…

I didn’t realize it was the margins of 2.54 cm that caused the troubles since apparently when you set indents the ruler counts from there and not from 0 cm (a bit illogical if you ask me haha). To try it out I changed the parper view margins to 0 cm and now the indents stay where they are when switching to editor view and vice versa.

A follow up question if you don’t mind… It’s possible that I’m kinda weird but I prefer a certain symmetry to the editor. By that I mean that left and and right from the indents I want exactly the same space to the Binder on the left and the inspector on the right. I know about the setting where you can say how many pixels it should be (currently 20 pixels) but when I change the width of either the Inspector or the Binder my careful positioning is being destroyed…
That’s the reason I wanted to switch to page view. No matter how you change the width of the Binder/Inspector there are always these small grey strips seperating the page from them. I just need some symmetry :unamused: Apart from that I prefer the editor, so I’m wondering if there are some settings for it… Thanks again.

It is if you think in terms of a word processor that starts counting from the edge of a sheet of paper, sure. :slight_smile: But in Scrivener there is no sheet of paper. It is not laying text out on a page. The logical place to start counting is where the text begins, because nothing “outside” or “around” the text exists yet.

Ah ha, yes we might have just the feature for you! It’s one I use as well as I am like you, I like to have text in a readable column down the middle of the editor space rather than crammed up on the left or spread out across a wide screen. At the same time I prefer no cuts between arbitrary “pages” like Page View does—so for me it is Fixed Width.

Go into the Editor preference pane, and just to the right of where you set up the visual margins you’ll see a “default editor width” section. Disable the third checkbox, Full screen only. You can adjust the width by pixels, and there are colour options as well in the Appearance preference pane.

Yeah this takes some time eto getting used to I guess.

You’re a saint thank you!!! Even if it basically looks like before when I manually set up the width it feels much better. It took numerous tries until I had the width like I wanted it as I’m not used to counting in pixels, I’d have much preferred to change the width centimeter wise, but it works. I have now exactly 2cm left and right from my indents.

As I tried around with the width though strange things happened to my indents. The left and first line indent moved like 1 or 2 pixels or so to the left and my right indent 4 to 5 pixels. Very strange. When I was finished I moved them back and for now at least they are fixed. That happened to me more than once though and completely at random. From one second to the other without messing around in the settings they shifted just a few pixels… It’s just a minor thing though (I hope) so if you don’t know what that is it’s okay.

Thanks again!

Do you mean the markers on the ruler shifted around? I’ve seen a few things that can cause the ruler to lose track of where the text is. It’s not perfect, but it’s the best we have to use. You can always double-check to make sure the actual stored indent values are correct, via the Format/Text/Tabs and Indents… command.

Yeah I meant the indent marker. So is that is know to happen? Yeah well it’s not tragic so it’s okay. I know about that command and I’ll remember when it happens the next time, thanks :slight_smile:

Yeah, and it shouldn’t even be an indent setting problem. The times I’ve seen it are just relating to how the ruler is drawn on the screen. The underlying settings for the paragraph ought to be fine.

Okay, I could have sworn though that at least once I checked the marker and it did infact move by 1 mm or so.