I want chapter titles on same page as document text. Can't make it happen.

My Chapters are set up as folders with simple number as titles: “Chapter 1”, etc.
Then the text files for each chapter in that folder.

In Compile - I look at the formatting examples and chose the one I want - the one with Chapter One mid page, then the document text starting just below it.

When I Compile, my doc preview shows each chapter heading on a separate page.

What am I doing wrong???

Thanks!

It sounds like the Layout you’ve chosen for text sections is requesting its own page break. Do you see any indication of that in the preview tile?

Alternatively (and less likely as it’s not a default setting), it might be the chapter Layout that is doing this. I recently posted some advice regarding putting the Part on its own page, in this thread. Note how a Layout can override the separator used by the section following it—in other words even if your text section layout is not using a page break separator, the chapter can stipulate that the first text section should.

Let us know what your Separators settings look like, if the source of the problem isn’t obvious.

Well, how about that. That does seem to be the problem. So I chose the preview showing the chapter title mid-page, etc.

Now I have a new problem. My text currently has extra spaces between paragraphs. So now I’m getting a # between every paragraph as that is the format determined by the same preview with the correct chapter heading. Sigh. It thinks the extra space means a new scene even though it’s all in the same text document.

So is there a way to KEEP this chapter heading format but get rid of the # every time there’s a space between paragraphs? I can’t seem to find a place to say don’t use the #.

And thanks for the early morning help!

Okay - never mind. Finally found the Projects Settings… tab.

I take it back. That’s not the settings screen I want. I can’t find the formatting screen that you have showing in the thread that you linked to above. Just can’t find that anywhere.

Do this:

  1. Open the Compile Screen.

  2. Select the "COMPILE FOR: " option on the very top (Print, PDF, Docx, etc…)

  3. See what happens on the left? As you select COMPILE FOR options, the options on the LEFT change.

  4. Good. Select one option on the left (single click with mouse. It is now highlighted blue (using normal MACOS colours)

  1. RIGHT CLICK now, and select “DUPLICATE & EDIT FORMAT”

  1. See the Screen mentioned in the link. Remember to save the format name to a DIFFERENT ONE. And enjoy.

  1. Now see? It is a saved as a new compile format (but ONLY for this particular project)

Cheers!

ZG

Ah-hah! So, you’re basically starting with one of the default formats then via the “duplicate & edit” with a new format name you are creating a custom format. Whew! Thanks!!!