Icon affects printing

(See attachment.)

There are two different icons for my chapters, one with and one without a small page image in the lower right corner. I don’t know what that represents other than compiling produces slightly different line spacing immediately following the chapter heading.

In the first instance I get a single paragraph mark at an increased font size; in the second it’s two paragraph marks at normal size.

I would like to have all chapter headings followed by a single mark. How do I get the icons to be consistent, as I can’t fathom why they’re different?
Scrivener icons.jpg

The overlay on the second icon indicates that the folder itself contains text. If you select the folder and disable the group view mode so that you see just the folder’s text, you can clean that up if it shouldn’t be there–sounds like it may contain an errant carriage return. Format > Options > Show Invisibles may help in that case.

That didn’t make any difference, Jennifer, but it’s raised another question. I can see how grouping occurs, but how have I managed to have so many chapters where grouping hasn’t taken place, yet the sections (text files) are indented and appear as such on the corkboard (i.e. as if they were grouped)?

EDIT: (Actually, they are grouped, but the icon doesn’t reflect this.)

Okay, I’m not quite sure what you mean by “grouping”. The corkboard shows only a single level of the hierarchy, so if you have a binder that looks like this:

A

  • 1
  • 2
    – a
    – b

Loading “A” on the corkboard will display index cards for only “1” and “2”. Because “2” also has subdocuments, its card will appear as a stack on the corkboard.

Scrivener allows both folders and text documents to have subdocuments. There is no difference shown in the binder icon of a folder to indicate whether or not it has subdocuments, but a text document that has subdocuments gets a stacked icon similar to how the cards are stacked on the corkboard. Whether this appears in the binder as stacked index cards, stacked blank pieces of paper, or stacked written-on paper depends on whether that parent document contains any text or has only a synopsis. So in the above set up, if “2” is a text document that has no synopsis and no text, its icon will appear as a stack of blank paper. If you add some text to “2” it will appear as a stack of written-on paper.

Icons are explained in section 8.2 of the user manual, with a table that shows the different types and what they indicate.

When you go to compile, the two things that matter for the formatting are an item’s type–folder, document, or document stack (i.e. a text document with subdocuments)–and its level in the binder hierarchy. Items immediately within the Draft folder are level 1, their children are level 2, their children level 3 and so on. Each item type at a given level in the hierarchy can be formatted uniquely, including which of its elements compile. You could have level 1 folders only include the title, for instance, so it wouldn’t matter whether that folder itself also contained text; the text wouldn’t be included.

Just working with the image you supplied, “Daniel in the den” and “Mending fences” are both folders at the same level, so in the compile formatting pane they are going to be treated the same. However, one contains text and one doesn’t, so if the folder text is being included in compile, you’d get a different result from the two; that was why I suggested checking the text on “Mending fences” and potentially deleting it. Since that didn’t affect your output, more knowledge of your compile settings would help. Could you share a screenshot or two of the compile formatting pane with the folder row selected that pertains to these two items, and showing the preview area beneath? If you click “Section Layout”, is there a prefix or suffix set for the folders? Finally, what is the Folder/Text separator (set in the Separators pane of compile)?

Thanks for the extensive reply, Jennifer.

By “grouping”, I meant the collection of text files within a folder.

My binder structure is limited to:

A

  • 1
  • 2
    B
  • 1
  • 2

No sub-documents.

The two level A files seem to be structured the same, leaving me puzzled as to why they have different icons. In the Word document resulting from the compile, the chapter structures are identical but for the spacing following the chapter headings.

I’ve attached images of the compile settings.



This might help: the two chapter headings with ‘Show paragraph marks’ on. There’s a difference in the amount of space between the headings and the first lines.

I still believe that they have different icons because, as MM said above, one of the folders (Mending fences) contains text, probably some white space or carriage return, which in turn is coming out on the compile. Try following these steps again:

  1. Select the Mending fences folder on the binder so it opens on the main editor.
  2. If scrivenings mode is enabled, disable it, so you’ll only have the folder’s text on the screen.
  3. Make sure that invisibles are being displayed (Format| Options| Show Invisibles)
  4. Remove any unneeded carriage returns from the document.

Does that help?

Yes, that helped, although it was viewing in the scrivenings mode that enabled me to see the carriage return. For a while now, I’ve been using corkboard mode, which explains why it was mostly earlier chapters that seemed most affected.

Thanks for your help, and many thanks also to Jennifer.